aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/ffmpeg26/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/ffmpeg26/Makefile')
-rw-r--r--multimedia/ffmpeg26/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/multimedia/ffmpeg26/Makefile b/multimedia/ffmpeg26/Makefile
index 4b99f78a4920..29a5b514e3b2 100644
--- a/multimedia/ffmpeg26/Makefile
+++ b/multimedia/ffmpeg26/Makefile
@@ -15,8 +15,7 @@ LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm \
- ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils \
- texi2html:${PORTSDIR}/textproc/texi2html
+ ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
UNIQUENAME= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
@@ -281,9 +280,14 @@ CONFIGURE_ARGS+=--prefix="${PREFIX}" \
DOC_FILES= Changelog CREDITS INSTALL.md LICENSE.md MAINTAINERS \
README.md RELEASE_NOTES
# under doc subdirectory
-DOC_DOCFILES= APIchanges *.txt *.html
+DOC_DOCFILES= APIchanges *.txt
PORTDOCS= *
+.if ${PORT_OPTIONS:MDOCS}
+DOC_DOCFILES+= *.html
+BUILD_DEPENDS+= texi2html:${PORTSDIR}/textproc/texi2html
+.endif
+
.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --disable-stripping
.else