aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/freevo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/freevo/Makefile')
-rw-r--r--multimedia/freevo/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/multimedia/freevo/Makefile b/multimedia/freevo/Makefile
index 8892a14c1816..61dfd6c93789 100644
--- a/multimedia/freevo/Makefile
+++ b/multimedia/freevo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: freevo
-# Date created: April 10 2004
-# Whom: Lewis Thompson (purple@lewiz.net)
-#
+# Created by: Lewis Thompson (purple@lewiz.net)
# $FreeBSD$
-#
PORTNAME= freevo
PORTVERSION= 1.9.0
@@ -54,15 +50,17 @@ CONFDIR= ${PREFIX}/etc/${PORTNAME}
DATADIR= ${PREFIX}/share/${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
-.if defined(WITHOUT_NLS)
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e 's| freevo_locale| # freevo_locale|' ${WRKSRC}/${PORTNAME}
@${MV} ${WRKSRC}/i18n ${WRKSRC}/i18n-nls-disabled
.endif