aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer-plugins/Makefile.common
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/gstreamer-plugins/Makefile.common')
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common15
1 files changed, 15 insertions, 0 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index 6f3a10f2316a..3a7bf63d2f0a 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -244,6 +244,15 @@ LIB_DEPENDS+= vorbisidec.1:${PORTSDIR}/audio/libtremor
DIST= bad
.endif
+# hal
+.if ${GST_PLUGIN}=="hal"
+LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
+PLIST_FILES= ${GST_LIB_DIR}/libgsthalelements.a \
+ ${GST_LIB_DIR}/libgsthalelements.la \
+ ${GST_LIB_DIR}/libgsthalelements.so
+
+.endif
+
# jpeg
.if ${GST_PLUGIN}=="jpeg"
LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
@@ -376,6 +385,12 @@ EXTRA_LIBS+= -lgsttag-${VERSION} -lgstaudio-${VERSION}
DIST= base
.endif
+# xvid
+.if ${GST_PLUGIN}=="xvid"
+LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
+DIST= bad
+.endif
+
# wavpack
.if ${GST_PLUGIN}=="wavpack"
LIB_DEPENDS+= wavpack.0:${PORTSDIR}/audio/wavpack