aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/gstreamer-plugins/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/gstreamer-plugins/Makefile')
-rw-r--r--multimedia/gstreamer-plugins/Makefile42
1 files changed, 23 insertions, 19 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 18c6a001a764..98cc56bbf3fe 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -43,6 +43,11 @@ CONFIGURE_ENV= PKG_CONFIG=${PKG_CONFIG} \
LDFLAGS="${LDFLAGS} -L${X11BASE}/lib -L${LOCALBASE}/lib ${EXTRA_LIBS} ${PTHREAD_LIBS}"
.include <bsd.port.pre.mk>
+.include "${MASTERDIR}/Makefile.common"
+
+#.if !defined(WITH_CPUFLAGS)
+WITHOUT_CPU_CFLAGS= yes
+#.endif
.if ${GST_PLUGIN} == "base"
GCONF_SCHEMAS= gstreamer-0.8.schemas
@@ -60,6 +65,10 @@ MAN1= gst-launch-ext-0.8.1 gst-visualise-0.8.1
EXTRA_BUILD_DIR+= sys/vcd
# modplug
EXTRA_BUILD_DIR+= gst/modplug
+.else
+.for f in ${GST_PLUGIN_DIR}
+GST_PLUGIN_MAKEFILES+= ${f}/Makefile
+.endfor
.endif
# cdrom default device
@@ -84,6 +93,17 @@ DEFAULT_DVD_DEVICE=/dev/acd0
. endif
.endif
+pre-everything::
+.if !defined(WITH_CPUFLAGS)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "If you want to compile with CPUFLAGS"
+ @${ECHO_MSG} "hit Ctrl+C now and use make \"WITH_CPUFLAGS=yes\""
+ @${ECHO_MSG} "NOTE: This option may cause build, install, and/or"
+ @${ECHO_MSG} "runtime failures. If this option does not work for you"
+ @${ECHO_MSG} "please do not use it."
+ @${ECHO_MSG} ""
+.endif
+
post-extract:
# for cdrom/vcd support
# taken from mplayer distfile
@@ -114,32 +134,17 @@ post-patch:
@${REINPLACE_CMD} -E \
-e 's|PFLAGS@|PFLAGS@ -I${LOCALBASE}/include/mjpegtools -I${LOCALBASE}/include/mjpegtools/mplex|' \
${WRKSRC}/ext/mplex/Makefile.in
-.if ${CXXFLAGS:M*=athlon-4} || ${CXXFLAGS:M*=athlon-mp} || ${CXXFLAGS:M*=athlon-xp}
-# Fix gst-register when using -O -march=athlon-xp
- @${REINPLACE_CMD} -e 's|@CXXF|-fgcse @CXXF|g' \
- ${WRKSRC}/gst/modplug/Makefile.in \
- ${WRKSRC}/gst/modplug/libmodplug/Makefile.in
+.if ${GST_PLUGIN}!="base"
+ @${REINPLACE_CMD} -E -e 's|ac_config_files=\"*\"|ac_config_files="$$ac_config_files Makefile ${GST_PLUGIN_MAKEFILES}" #|' \
+ ${WRKSRC}/configure
.endif
-pre-build:
-# This port cannot be CFLAGS safe, when using p4 optimizations
-# because it breaks the mod plugin
- @${REINPLACE_CMD} -E \
- -e 's|(-march=pentiu)m4|\1m3|g' \
- -e 's|(-mcpu=pentiu)m4|\1m3|g' \
- -e 's|(-mtune=pentiu)m)4|\1m3|g' \
- ${WRKSRC}/gst/modplug/Makefile \
- ${WRKSRC}/gst/modplug/libmodplug/Makefile
-
post-build:
.ifdef(EXTRA_BUILD_DIR)
. for dir in ${EXTRA_BUILD_DIR}
@cd ${WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}
. endfor
.endif
-# @${ECHO_CMD} "@unexec ${PREFIX}/bin/gst-register-${GST_VERSION} \
-# --gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${GST_VERSION}/registry.xml \
-# >> ${TMPPLIST}"
post-install:
.ifdef(EXTRA_BUILD_DIR)
@@ -151,5 +156,4 @@ post-install:
-@${X11BASE}/bin/gst-register-${GST_VERSION} \
--gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${GST_VERSION}/registry.xml 2>/dev/null
-.include "${MASTERDIR}/Makefile.common"
.include <bsd.port.post.mk>
8&id=b5a5b67ba5a2cba9b731f4765be218a55b5a55ce'>This appears to be broken globally on 5.x.kris2004-04-111-2/+2 * Tidy up whitespace.trevor2004-04-117-9/+7 * Cram into 80 columns by 24 rows.trevor2004-04-113-42/+22 * Trim whitespace.trevor2004-04-111-52/+52 * Remove the part about installing the cups-lpr port because thedannyboy2004-04-101-5/+0 * Duplicate the relevant parts of the former cups-base pkg-messagedannyboy2004-04-101-0/+15 * Add missing WWW.dannyboy2004-04-101-0/+2 * Update to 2.6.0.1bland2004-04-083-4/+8 * - tar -> ${TAR} (since we have now a bsdtar ;)clement2004-04-071-1/+1 * Fix typos in pkg-descr and COMMENT that survived nearly 7 yearsarved2004-04-072-3/+3 * Chase the glib20 update, and bump all affected ports' PORTREVISIONs.marcus2004-04-058-8/+8 * Add a patch forgotten by the merge script.marcus2004-04-051-0/+11 * Presenting GNOME 2.6.0. The FreeBSD GNOME Team feels this our best releasemarcus2004-04-0510-38/+41 * Back out previous commit (I lost a race condition with hrs who fixedkris2004-04-031-2/+0 * Remove category pkg/COMMENT files in favour of a COMMENT variable in thekris2004-04-022-1/+2 * Add pdftk, a simple tool for doing everyday things with PDF documents.pav2004-04-024-0/+63 * SIZEify (maintainer timeout)trevor2004-03-3168-0/+380 * BROKEN on amd64: Does not compilekris2004-03-291-2/+2 * BROKEN: Does not installkris2004-03-291-0/+2 * - SIZEifymarkus2004-03-292-0/+2 * - SIZE'ifykrion2004-03-272-0/+2 * - make PKGNAMESUFFIX more flexibledinoex2004-03-271-1/+1 * - Improve papersize handling of LIPS driverkrion2004-03-268-28/+262 * - Generate pkg-plist on the fly.krion2004-03-262-14/+18 * - Generate pkg-plist on the fly.krion2004-03-262-17/+18 * - Generate pkg-plist on the fly.krion2004-03-262-17/+18 * - Generate pkg-plist on the fly.krion2004-03-262-14/+18 * - Generate pkg-plist on the fly.krion2004-03-262-13/+14 * - Generate pkg-plist on the fly.krion2004-03-252-50/+20 * SIZE update jumbo-commit.bms2004-03-251-0/+1 * Add size data, approved by maintainers.trevor2004-03-251-0/+1 * - Update to 1.6.4pav2004-03-256-286/+369 * - Fix WWW:krion2004-03-232-48/+40 * - Update to version 2.10krion2004-03-233-252/+102 * Retire this port. It has served its purpose, and now everything thatmarcus2004-03-239-235/+0 * Fix build with freetype2-2.1.7.marcus2004-03-2312-0/+144 * Update to 2.1.7 to fix the build with freetype2-2.1.7.marcus2004-03-232-3/+3 * Add SIZE data.knu2004-03-224-0/+4 * Add SIZE information.jkoshy2004-03-221-0/+1 * - Remove print/rubber, it's duplicate of textproc/rubber.pav2004-03-226-101/+0 * Fix build with freetyp2-2.1.7.marcus2004-03-221-0/+12 * - Some style changeskrion2004-03-212-24/+29 * - Add share/texmf-local/web2c and some style changes.krion2004-03-212-11/+13 * Move the ancient emacs 19.x port from editors/emacs tokris2004-03-211-2/+2 * - Fix build with freetype-2.1.7krion2004-03-206-0/+42 * Revert the previous commit. It was a nice idea, and worked in many cases,marcus2004-03-193-102/+1 * Fix the height and width calculations for BDF/PCF fonts. This fixes themarcus2004-03-193-0/+102 * Add size data, approved by maintainers.trevor2004-03-1919-0/+322 * reset MAINTAINER bit to ports@vanilla2004-03-191-1/+1 * Add SIZE.vanilla2004-03-191-0/+1 * - Add SIZE to GNOME portspav2004-03-188-0/+8 * Add SIZE data.perky2004-03-181-0/+1 * Add size data.trevor2004-03-188-0/+20 * s/pre-install/pre-su-install/ because we're creating directories undermarcel2004-03-182-2/+2 * SIZEify.trevor2004-03-189-0/+56 * - clean empty dirs man/fr/man?dinoex2004-03-181-0/+5 * Update to 2.1.7. For a list of what's changed, please see:marcus2004-03-173-14/+15 * - Update to version 1.0.29krion2004-03-152-5/+3 * update to xfce 4.0.4oliver2004-03-153-6/+8 * Mark BROKEN: Checksum mismatchkrion2004-03-151-0/+2 * - Fix build with qt-33krion2004-03-151-0/+5 * Whoa there, boy, that's a mighty big commit y'all have there...ade2004-03-1425-25/+25 * BROKEN on alpha 4.x: Coredump during buildkris2004-03-141-0/+4 * BROKEN on alpha 4.x: coredump during buildkris2004-03-141-0/+4 * Now that the SIZE thing has stabilized, add it to the ports I maintain.dougb2004-03-141-0/+1 * Fix build with gtk+-2.4.marcus2004-03-141-0/+3 * - Update to version 0.35krion2004-03-144-87/+38 * deUSE_SIZEify.obraun2004-03-111-1/+0 * - Update MASTER_SITES and WWW: linekrion2004-03-104-27/+23 * - Fix BUILD_DEPENDSkrion2004-03-085-5/+10 * BROKEN on alpha 5.x: Does not compilekris2004-03-071-1/+7 * Add latex-lineno 3.10.20031112,krion2004-03-065-0/+73 * Add latex-arydshln 1.6.20030825,krion2004-03-065-0/+78 * - Fix build on -stable with Qt frontendkrion2004-03-0510-30/+495 * Add latex-pict2e 0.2.20040219,krion2004-03-055-0/+98 * - Update to version 2.01krion2004-03-043-46/+75 * - Update to version 0.60krion2004-03-042-30/+19 * - Update to version 1.09krion2004-03-042-14/+13 * BROKEN on alpha 5.x as well: does not compilekris2004-03-031-1/+2 * - Fix install in clean environmentpav2004-03-021-0/+2 * - rpm2cpio.pl need to be EXTRACT_DEPENDS otherwise it will not workpav2004-03-021-1/+1 * Update to 1.3.4arved2004-03-0120-135/+80 * Use USE_GMAKE to fix the build.adamw2004-03-011-0/+1 * - Update to version 8.14krion2004-02-2927-1764/+2151 * - install dvipdfm map file txr3.mappav2004-02-292-0/+5 * - honour PAPERSIZE variable like in a2ps and psutils portsandreas2004-02-281-9/+18 * Add tipa, a collection of fonts and macros to use the T3-encoded IPA with LaT...pav2004-02-289-0/+593 * Remove qmake from RUN_DEPENDS in x11-toolkits/qt32 and chase ports whichlofi2004-02-271-0/+2 * - sketch is now called skencilandreas2004-02-261-1/+1 * (Purportedly) unbreak installation as per some of the responses in thegreen2004-02-2610-20/+75 * - add CONFLICTSdinoex2004-02-252-1/+11 * Change my email address.markus2004-02-242-2/+2 * - Update to 2.1.19pav2004-02-234-85/+96 * - Update to version 3.0.20040123krion2004-02-232-8/+10 * BROKEN: Checksum mismatchkris2004-02-221-0/+2 * Reset bouncing maintainer addresskris2004-02-221-1/+1 * BROKEN: Checksum mismatchkris2004-02-221-0/+2 * BROKEN on 4.x: Does not compilekris2004-02-221-0/+4 * Fix make patch after gettext PORTREVISION bump by using DISTNAME instead ofmarcus2004-02-211-12/+10 * - Update to 2.0.3pav2004-02-202-4/+3 * - Unbreak this port and fix build.krion2004-02-181-4/+3 * BROKEN: Missing dependencykris2004-02-171-0/+2 * Reset undeliverable maintainer addresskris2004-02-175-5/+5 * BROKEN: Does not install. This port is scheduled for removal on April 16kris2004-02-175-0/+20 * BROKEN: Fails to patchkris2004-02-161-0/+2 * - Update to version 1.97krion2004-02-143-11/+10 * Add latex-logpap 0.6.20040201,krion2004-02-145-0/+80 * - Fix build on AMD64krion2004-02-101-2/+15 * Update to 2.3 and add ftp.ctan.org into $MASTER_SITES. (Committer'slinimon2004-02-093-6/+10 * A new tarball was re-rolled with my fix for pdflib-perl.ale2004-02-092-2/+2 * Replace delta with via dvipdfmx CVSweb. Rewrite comments.matusita2004-02-091-58/+33 * Add two patches:matusita2004-02-093-2/+118 * Fix extraction by using DISTNAME instead of PKGNAME for the name of themarcus2004-02-081-10/+10 * USE_SIZEifylioux2004-02-082-0/+2 * BROKEN on 5.x: Configure failskris2004-02-081-1/+7 * Update to 1.1.14.lofi2004-02-072-2/+3 * Use PLIST_FILES (bento-tested, marcus-reviewed).trevor2004-02-0624-12/+13 * Use PLIST_FILES.trevor2004-02-0616-12/+12 * Make sure the libgimpprint.so library is linked against libintl to resolvemarcus2004-02-056-3/+36 * Update to 2.4.1.marcus2004-02-052-3/+3 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-041-0/+1 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-0461-11/+61 * Add USE_GETTEXT and bump PORTREVISION.marcus2004-02-0410-17/+22 * Fix some fallout from the permissions-fix.lofi2004-02-042-2/+0 * Remove the mentions of pool_size and max_strings, as newer versions ofnik2004-02-041-2/+0 * Update to 1.24, and hand maintainership over to hrs.nik2004-02-044-26/+115 * - Updte to version 0.5krion2004-02-033-16/+14 * Unmark FORBIDDEN, and fix the permissions issue.marcus2004-02-033-6/+3 * The tarball fetched from several CTAN mirror sites seemnork2004-02-03