aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/kdenlive
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/kdenlive')
-rw-r--r--multimedia/kdenlive/Makefile51
-rw-r--r--multimedia/kdenlive/distinfo3
-rw-r--r--multimedia/kdenlive/pkg-descr7
-rw-r--r--multimedia/kdenlive/pkg-plist153
4 files changed, 214 insertions, 0 deletions
diff --git a/multimedia/kdenlive/Makefile b/multimedia/kdenlive/Makefile
new file mode 100644
index 000000000000..e2ad41e22b2c
--- /dev/null
+++ b/multimedia/kdenlive/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: kdenlive
+# Date created: 15 October 2008
+# Whom: Alberto Villa <villa.alberto@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= kdenlive
+PORTVERSION= 0.7
+CATEGORIES= multimedia kde
+MASTER_SITES= SFE
+
+MAINTAINER= villa.alberto@gmail.com
+COMMENT= A professional quality non-linear video editing suite for KDE
+
+LIB_DEPENDS= avformat.1:${PORTSDIR}/multimedia/ffmpeg \
+ mlt.1:${PORTSDIR}/multimedia/mlt \
+ mlt++.1:${PORTSDIR}/multimedia/mlt++
+
+USE_GETTEXT= yes
+USE_KDE4= automoc4 kdehier kdelibs kdeprefix sharedmime
+USE_QT_VER= 4
+QT_COMPONENTS= dbus gui network svg xml \
+ moc_build qmake_build rcc_build uic_build
+USE_CMAKE= yes
+CMAKE_ARGS= -DNO_JOGSHUTTLE:BOOL=On
+
+PORTDOCS= AUTHORS COPYING INSTALL README
+
+OPTIONS= LADSPA "Install LADSPA plugins" on
+
+.include <bsd.port.pre.mk>
+
+.ifdef(WITH_LADSPA)
+RUN_DEPENDS+= swhplugins>=0:${PORTSDIR}/audio/swhplugins
+.endif
+
+post-patch:
+ # prevent updating mime during build
+ ${REINPLACE_CMD} -e '/^update_xdg_mimetypes/d; /SharedMimeInfo/d' \
+ ${PATCH_WRKSRC}/src/mimetypes/CMakeLists.txt
+
+post-install:
+ @-update-mime-database ${KDE4_PREFIX}/share/mime
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/kdenlive/distinfo b/multimedia/kdenlive/distinfo
new file mode 100644
index 000000000000..c8d2b67f9fed
--- /dev/null
+++ b/multimedia/kdenlive/distinfo
@@ -0,0 +1,3 @@
+MD5 (kdenlive-0.7.tar.gz) = dfca2fe1fe72737d7f6af80af9c73788
+SHA256 (kdenlive-0.7.tar.gz) = 3fc59fe0be10585577f9dc08a8f9cc0a653361deaad1edcfaae21c859dd31a7d
+SIZE (kdenlive-0.7.tar.gz) = 523216
diff --git a/multimedia/kdenlive/pkg-descr b/multimedia/kdenlive/pkg-descr
new file mode 100644
index 000000000000..8ae4bd135035
--- /dev/null
+++ b/multimedia/kdenlive/pkg-descr
@@ -0,0 +1,7 @@
+Kdenlive is a non-linear video editor for GNU/Linux and FreeBSD,
+which supports DV, HDV and AVCHD (not complete yet) editing. Kdenlive
+relies on several other open source projects like FFmpeg and the
+MLT video framework. It was designed to answer all needs, from
+basic video editing to semi-professional work.
+
+WWW: http://www.kdenlive.org
diff --git a/multimedia/kdenlive/pkg-plist b/multimedia/kdenlive/pkg-plist
new file mode 100644
index 000000000000..0bc45a0a0399
--- /dev/null
+++ b/multimedia/kdenlive/pkg-plist
@@ -0,0 +1,153 @@
+bin/kdenlive
+bin/kdenlive_render
+lib/kde4/westleypreview.so
+share/applications/kde/kdenlive.desktop
+share/apps/kdenlive/banner.png
+share/apps/kdenlive/blacklisted_effects.txt
+share/apps/kdenlive/blacklisted_transitions.txt
+share/apps/kdenlive/effects/automask.xml
+share/apps/kdenlive/effects/boxblur.xml
+share/apps/kdenlive/effects/brightness.xml
+share/apps/kdenlive/effects/charcoal.xml
+share/apps/kdenlive/effects/chroma.xml
+share/apps/kdenlive/effects/chroma_hold.xml
+share/apps/kdenlive/effects/fadein.xml
+share/apps/kdenlive/effects/fadeout.xml
+share/apps/kdenlive/effects/freeze.xml
+share/apps/kdenlive/effects/frei0r_distort0r.xml
+share/apps/kdenlive/effects/frei0r_squareblur.xml
+share/apps/kdenlive/effects/gamma.xml
+share/apps/kdenlive/effects/greyscale.xml
+share/apps/kdenlive/effects/invert.xml
+share/apps/kdenlive/effects/ladspa_declipper.xml
+share/apps/kdenlive/effects/ladspa_equalizer.xml
+share/apps/kdenlive/effects/ladspa_limiter.xml
+share/apps/kdenlive/effects/ladspa_phaser.xml
+share/apps/kdenlive/effects/ladspa_pitch.xml
+share/apps/kdenlive/effects/ladspa_pitch_scale.xml
+share/apps/kdenlive/effects/ladspa_rate_scale.xml
+share/apps/kdenlive/effects/ladspa_reverb.xml
+share/apps/kdenlive/effects/ladspa_room_reverb.xml
+share/apps/kdenlive/effects/ladspa_vinyl.xml
+share/apps/kdenlive/effects/mirror.xml
+share/apps/kdenlive/effects/mute.xml
+share/apps/kdenlive/effects/normalise.xml
+share/apps/kdenlive/effects/obscure.xml
+share/apps/kdenlive/effects/rotation.xml
+share/apps/kdenlive/effects/sepia.xml
+share/apps/kdenlive/effects/sox_echo.xml
+share/apps/kdenlive/effects/sox_flanger.xml
+share/apps/kdenlive/effects/sox_pitch.xml
+share/apps/kdenlive/effects/sox_reverb.xml
+share/apps/kdenlive/effects/sox_vibro.xml
+share/apps/kdenlive/effects/threshold.xml
+share/apps/kdenlive/effects/volume.xml
+share/apps/kdenlive/effects/wave.xml
+share/apps/kdenlive/export/profiles.xml
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-add-clip.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-add-color-clip.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-add-slide-clip.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-add-text-clip.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-align-hor.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-align-vert.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-hide-audio.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-hide-video.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-insert-rect.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-show-audio.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-show-audiothumb.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-show-markers.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-show-video.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-show-videothumb.png
+share/apps/kdenlive/icons/hicolor/16x16/actions/kdenlive-snap.png
+share/apps/kdenlive/icons/hicolor/scalable/actions/kdenlive-select-tool.svgz
+share/apps/kdenlive/icons/hicolor/scalable/actions/kdenlive-zone-end.svgz
+share/apps/kdenlive/icons/hicolor/scalable/actions/kdenlive-zone-start.svgz
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-add-clip.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-add-color-clip.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-add-slide-clip.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-add-text-clip.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-align-hor.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-align-vert.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-hide-audio.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-hide-video.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-insert-rect.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-show-audio.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-show-audiothumb.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-show-markers.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-show-video.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-show-videothumb.png
+share/apps/kdenlive/icons/oxygen/16x16/actions/kdenlive-snap.png
+share/apps/kdenlive/icons/oxygen/scalable/actions/kdenlive-select-tool.svgz
+share/apps/kdenlive/icons/oxygen/scalable/actions/kdenlive-zone-end.svgz
+share/apps/kdenlive/icons/oxygen/scalable/actions/kdenlive-zone-start.svgz
+share/apps/kdenlive/kdenlive.notifyrc
+share/apps/kdenlive/kdenliveui.rc
+share/apps/kdenlive/metadata.properties
+share/apps/kdenlive/timeline_athumbs.png
+share/apps/kdenlive/timeline_avthumbs.png
+share/apps/kdenlive/timeline_nothumbs.png
+share/apps/kdenlive/timeline_vthumbs.png
+share/apps/kdenlive/transition.png
+share/config.kcfg/kdenlivesettings.kcfg
+share/icons/hicolor/32x32/apps/kdenlive.png
+share/icons/hicolor/48x48/apps/kdenlive.png
+share/icons/hicolor/64x64/apps/kdenlive.png
+share/icons/oxygen/32x32/apps/kdenlive.png
+share/icons/oxygen/48x48/apps/kdenlive.png
+share/icons/oxygen/64x64/apps/kdenlive.png
+share/icons/oxygen/scalable/mimetypes/application-x-kdenlive.svgz
+share/icons/oxygen/scalable/mimetypes/video-mlt-playlist.svgz
+share/kde4/services/westleypreview.desktop
+share/locale/ca/LC_MESSAGES/kdenlive.mo
+share/locale/cs/LC_MESSAGES/kdenlive.mo
+share/locale/da/LC_MESSAGES/kdenlive.mo
+share/locale/de/LC_MESSAGES/kdenlive.mo
+share/locale/es/LC_MESSAGES/kdenlive.mo
+share/locale/fr/LC_MESSAGES/kdenlive.mo
+share/locale/it/LC_MESSAGES/kdenlive.mo
+share/locale/nl/LC_MESSAGES/kdenlive.mo
+share/locale/zh/LC_MESSAGES/kdenlive.mo
+share/mime/application/x-kdenlive.xml
+share/mime/packages/kdenlive.xml
+share/mime/packages/westley.xml
+share/mime/video/mlt-playlist.xml
+@dirrmtry share/kde4/services
+@dirrmtry share/kde4
+@dirrmtry share/icons/oxygen/scalable/mimetypes
+@dirrmtry share/icons/oxygen/scalable
+@dirrmtry share/icons/oxygen/64x64/apps
+@dirrmtry share/icons/oxygen/64x64
+@dirrmtry share/icons/oxygen/48x48/apps
+@dirrmtry share/icons/oxygen/48x48
+@dirrmtry share/icons/oxygen/32x32/apps
+@dirrmtry share/icons/oxygen/32x32
+@dirrmtry share/icons/oxygen
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/config.kcfg
+@dirrm share/apps/kdenlive/icons/oxygen/scalable/actions
+@dirrm share/apps/kdenlive/icons/oxygen/scalable
+@dirrm share/apps/kdenlive/icons/oxygen/16x16/actions
+@dirrm share/apps/kdenlive/icons/oxygen/16x16
+@dirrm share/apps/kdenlive/icons/oxygen
+@dirrm share/apps/kdenlive/icons/hicolor/scalable/actions
+@dirrm share/apps/kdenlive/icons/hicolor/scalable
+@dirrm share/apps/kdenlive/icons/hicolor/16x16/actions
+@dirrm share/apps/kdenlive/icons/hicolor/16x16
+@dirrm share/apps/kdenlive/icons/hicolor
+@dirrm share/apps/kdenlive/icons
+@dirrm share/apps/kdenlive/export
+@dirrm share/apps/kdenlive/effects
+@dirrm share/apps/kdenlive
+@dirrmtry share/apps
+@dirrmtry share/applications/kde
+@dirrmtry share/applications
+@dirrmtry lib/kde4
+@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime > /dev/null || /usr/bin/true