aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/kino/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/kino/Makefile')
-rw-r--r--multimedia/kino/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/multimedia/kino/Makefile b/multimedia/kino/Makefile
index ef475d7359a7..29caa7185f82 100644
--- a/multimedia/kino/Makefile
+++ b/multimedia/kino/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kino
PORTVERSION= 0.7.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= multimedia
MASTER_SITES= http://kino.schirmacher.de/filemanager/download/42/ \
http://perso.enst.fr/~beyssac/mirrors/
@@ -20,9 +20,11 @@ LIB_DEPENDS= dv.4:${PORTSDIR}/multimedia/libdv \
Magick.8:${PORTSDIR}/graphics/ImageMagick \
samplerate.1:${PORTSDIR}/audio/libsamplerate
+OPTIONS= QUICKTIME "With Quicktime support" off
+
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= libgnomeui libxml2
+USE_GNOME= gnomehack gnomeprefix libgnomeui libxml2
USE_ICONV= yes
GNU_CONFIGURE= yes
USE_X_PREFIX= yes
@@ -31,4 +33,11 @@ CONFIGURE_ENV= CPPFLAGS=-"I${LOCALBASE}/include -I${X11BASE}/include" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
MAN1= kino.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_QUICKTIME)
+LIB_DEPENDS+= quicktime.0:${PORTSDIR}/multimedia/libquicktime
+CONFIGURE_ARGS+= --with-quicktime
+.endif
+
+.include <bsd.port.post.mk>