aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mkvtoolnix/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/mkvtoolnix/Makefile')
-rw-r--r--multimedia/mkvtoolnix/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
new file mode 100644
index 000000000000..efbf773995be
--- /dev/null
+++ b/multimedia/mkvtoolnix/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: mkvtoolnix
+# Date created: Tue Feb 24 02:09:12 UTC 2004
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mkvtoolnix
+PORTVERSION= 0.8.5
+CATEGORIES= multimedia audio
+MASTER_SITES= http://www.bunkus.org/videotools/mkvtoolnix/sources/
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Tools to extract from/get info about/create Matroska media streams
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libmatroska.a:${PORTSDIR}/multimedia/libmatroska \
+ ${LOCALBASE}/lib/libebml.a:${PORTSDIR}/textproc/libebml
+LIB_DEPENDS= FLAC.5:${PORTSDIR}/audio/flac \
+ vorbis.3:${PORTSDIR}/audio/libvorbis
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_SIZE= yes
+USE_ICONV= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-extra-includes=${LOCALBASE}/include \
+ --with-extra-libs=${LOCALBASE}/lib
+
+MAN1= base64tool.1 mkvextract.1 mkvinfo.1 mkvmerge.1 mmg.1
+
+post-patch:
+# disable GNU auto* tools
+ @${FIND} ${WRKSRC} -type f -name "Makefile.in" | ${XARGS} \
+ -n 10 ${REINPLACE_CMD} -E -e \
+ 's!^(ACLOCAL|AUTOCONF|AUTOMAKE|AUTOHEADER).+$$!\1=${TRUE}!'
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+# this is gcc 2.x
+CFLAGS+= -DNO_WSTRING
+# use gcc 3.2
+USE_GCC=3.2
+.else
+# default for 5.x series
+USE_GCC=3.3
+.endif
+
+.include <bsd.port.post.mk>