aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mlt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/mlt/Makefile')
-rw-r--r--multimedia/mlt/Makefile43
1 files changed, 12 insertions, 31 deletions
diff --git a/multimedia/mlt/Makefile b/multimedia/mlt/Makefile
index ab5f339480a2..b13951ea91d2 100644
--- a/multimedia/mlt/Makefile
+++ b/multimedia/mlt/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= mlt
-PORTVERSION= 0.3.8
+PORTVERSION= 0.4.2
CATEGORIES= multimedia
MASTER_SITES= SFE
@@ -18,15 +18,16 @@ USE_SDL= image
MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-debug \
- --enable-gpl \
- --enable-sdl \
- --enable-westley
+ --enable-gpl
USE_GMAKE= yes
CFLAGS+= -I${LOCALBASE}/include
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/mlt
+NOT_FOR_ARCHS= sparc64
+NOT_FOR_ARCHS_REASON_sparc64= does not compile on sparc64 (invokes i386 asm)
+
PORTDOCS= AUTHORS ChangeLog COPYING \
- GPL NEWS README docs demo
+ NEWS README docs demo
OPTIONS= AVFORMAT "Avformat module" on \
DV "Quasar DV Codec module" on \
@@ -34,19 +35,15 @@ OPTIONS= AVFORMAT "Avformat module" on \
GTK2 "GTK2 module" on \
JACKRACK "JACK Rack module" on \
KINO "Kino module" on \
- MMX "MMX support (ignored on x86-64)" on \
QIMAGE "Qimage module" on \
RESAMPLE "Secret Rabbit Code module" on \
SOX "Sound eXchange module" on \
- SSE "SSE support (requires MMX)" on \
VORBIS "Vorbis module" on
.include <bsd.port.pre.mk>
.ifdef(WITH_AVFORMAT)
-# one of them could be disabled
-LIB_DEPENDS+= avformat.1:${PORTSDIR}/multimedia/ffmpeg \
- swscale.1:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS+= avformat.1:${PORTSDIR}/multimedia/ffmpeg
CONFIGURE_ARGS+= --enable-avformat \
--avformat-swscale
PLIST_SUB+= AVFORMAT=""
@@ -102,12 +99,6 @@ CONFIGURE+ARGS+= --disable-kino
PLIST_SUB+= KINO="@comment "
.endif
-.if defined(WITH_MMX) && ${MACHINE_CPU:Mmmx} != ""
-CONFIGURE_ARGS+= --enable-mmx
-.else
-CONFIGURE_ARGS+= --disable-mmx
-.endif
-
.ifdef(WITH_QIMAGE)
CONFIGURE_ARGS+= --enable-qimage \
--qimage-includedir="${QT_INCDIR}" \
@@ -137,15 +128,6 @@ CONFIGURE_ARGS+= --disable-sox
PLIST_SUB+= SOX="@comment "
.endif
-# sse can be enabled only with mmx
-.if defined(WITH_MMX) && ${MACHINE_CPU:Mmmx} != ""
-.if defined(WITH_SSE) && ${MACHINE_CPU:Msse} != ""
-CONFIGURE_ARGS+= --enable-sse
-.else
-CONFIGURE_ARGS+= --disable-sse
-.endif
-.endif
-
.ifdef(WITH_VORBIS)
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+= --enable-vorbis
@@ -155,15 +137,14 @@ CONFIGURE_ARGS+= --disable-vorbis
PLIST_SUB+= VORBIS="@comment "
.endif
-.if ${ARCH} == "sparc64"
-IGNORE= does not compile on sparc64 (invokes i386 asm)
-.endif
-
pre-configure:
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/configure
+ ${WRKSRC}/configure \
+ ${WRKSRC}/src/swig/*/build
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/src/*/Makefile
+ ${WRKSRC}/src/framework/Makefile \
+ ${WRKSRC}/src/melt/Makefile \
+ ${WRKSRC}/src/modules/*/Makefile
@${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
${WRKSRC}/Makefile