aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/mpeg4ip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/mpeg4ip/Makefile')
-rw-r--r--multimedia/mpeg4ip/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/multimedia/mpeg4ip/Makefile b/multimedia/mpeg4ip/Makefile
index dba38ef4f18d..baa7699a3a32 100644
--- a/multimedia/mpeg4ip/Makefile
+++ b/multimedia/mpeg4ip/Makefile
@@ -31,12 +31,13 @@ USE_GNOME= gtk20
USE_SDL= sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include/SDL11 -I${LOCALBASE}/include/ffmpeg -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --enable-ffmpeg=${LOCALBASE} \
--enable-mp4live \
--disable-static
-INSTALLS_SHLIB= yes
+
OPTIONS= ARTS "Enable Arts Support" Off \
ESOUND "Enable Esound Support" Off \
@@ -86,6 +87,9 @@ MAN3= MP4.3 MP4AddAudioTrack.3 MP4AddHintTrack.3 MP4AddODTrack.3 \
.if ${OSVERSION} < 500000
CFLAGS+= -O2
+PLIST_SUB+= GCC="@comment "
+.else
+PLIST_SUB+= GCC=""
.endif
###