aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/multicat/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/multicat/Makefile')
-rw-r--r--multimedia/multicat/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/multimedia/multicat/Makefile b/multimedia/multicat/Makefile
new file mode 100644
index 000000000000..ae7b98689388
--- /dev/null
+++ b/multimedia/multicat/Makefile
@@ -0,0 +1,39 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= multicat
+PORTVERSION= git20161007
+CATEGORIES= net multimedia
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Simple and efficient multicast and transport stream manipulation
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${LOCALBASE}/include/bitstream/mpeg/ts.h:multimedia/bitstream
+
+USE_GITHUB= yes # XXX: FreeBSD fixes not upstreamed yet
+GH_ACCOUNT= AMDmi3
+GH_TAGNAME= b551ed4
+
+USES= localbase
+ALL_TARGET= ${PORTNAME}
+
+PORTDOCS= AUTHORS Changelog NEWS README
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>