aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/py-periscope/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/py-periscope/Makefile')
-rw-r--r--multimedia/py-periscope/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/multimedia/py-periscope/Makefile b/multimedia/py-periscope/Makefile
new file mode 100644
index 000000000000..1aaa5a12eb08
--- /dev/null
+++ b/multimedia/py-periscope/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: periscope
+# Date created: Sun Jul 24 20:23:58 UTC 2011
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= periscope
+PORTVERSION= 0.2.4
+CATEGORIES= multimedia python
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTFILES= python-${PORTNAME}_${PORTVERSION}.orig${EXTRACT_SUFX} \
+ periscope.desktop
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= python-${PORTNAME}_${PORTVERSION}.orig${EXTRACT_SUFX}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Subtitles searching module
+
+LICENSE= LGPL3
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=3.2.0:${PORTSDIR}/www/py-beautifulsoup
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+USE_GNOME= desktopfileutils
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+NO_WRKSUBDIR= yes
+
+PLIST_SUB= DESKTOPDIR=${DESKTOPDIR_WITHOUT_PREFIX:Q}
+
+DESKTOPDIR_WITHOUT_PREFIX= ${DESKTOPDIR:S,^${PREFIX}/,,}
+
+post-install:
+ @${MKDIR} ${DESKTOPDIR}
+ @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/periscope.desktop \
+ ${DESKTOPDIR}
+ @-${LOCALBASE}/bin/update-desktop-database
+
+.include <bsd.port.mk>