aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/smpeg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/smpeg/Makefile')
-rw-r--r--multimedia/smpeg/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/multimedia/smpeg/Makefile b/multimedia/smpeg/Makefile
index 0b6241c21d15..81789ccbde0b 100644
--- a/multimedia/smpeg/Makefile
+++ b/multimedia/smpeg/Makefile
@@ -6,25 +6,28 @@
#
PORTNAME= smpeg
-PORTVERSION= 0.3.3
+PORTVERSION= 0.3.5
CATEGORIES= graphics
MASTER_SITES= http://www.lokigames.com/development/download/smpeg/
MAINTAINER= cpiazza@FreeBSD.org
-LIB_DEPENDS= SDL-1.0.2:${PORTSDIR}/devel/sdl \
+LIB_DEPENDS= SDL-1.1.2:${PORTSDIR}/devel/sdl-devel \
gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
GTK_CONFIG= ${X11BASE}/bin/gtk12-config
+SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
+ SDL_CONFIG="${SDL_CONFIG}" \
GLBASE="${X11BASE}" \
CPPFLAGS="-I${X11BASE}/include"
#If you want to try the opengl player (which doesn't seem to work)
#comment out the following line.
-CONFIGURE_ARGS= --disable-opengl-player
+CONFIGURE_ARGS= --disable-opengl-player \
+ --enable-mmx
MAN1= gtv.1 plaympeg.1