aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/subtitlecomposer-kde4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/subtitlecomposer-kde4/Makefile')
-rw-r--r--multimedia/subtitlecomposer-kde4/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/multimedia/subtitlecomposer-kde4/Makefile b/multimedia/subtitlecomposer-kde4/Makefile
index e370d67bdac5..8783c6f9fced 100644
--- a/multimedia/subtitlecomposer-kde4/Makefile
+++ b/multimedia/subtitlecomposer-kde4/Makefile
@@ -6,9 +6,8 @@
#
PORTNAME= subtitlecomposer
-PORTVERSION= 0.4.3
-PORTREVISION= 1
-CATEGORIES= multimedia
+PORTVERSION= 0.5.2
+CATEGORIES= multimedia kde
MASTER_SITES= SF
MASTER_SITE_SUBDIR=subcomposer
@@ -16,18 +15,17 @@ MAINTAINER= makc@FreeBSD.org
COMMENT= Subtitle editor for KDE
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool:15
-USE_KDELIBS_VER=3
-USE_XORG= xext
-GNU_CONFIGURE= yes
+USE_CMAKE= yes
+USE_KDE4= kdeprefix kdelibs automoc4
+USE_QT_VER= 4
+QT_COMPONENTS= gui qmake_build moc_build rcc_build uic_build
WANT_GSTREAMER= yes
-INSTALLS_ICONS= yes
-PORTSCOUT= limit:^0\.4\.
+LATEST_LINK= ${PORTNAME}-kde4
OPTIONS= MPLAYER "Enable MPlayer backend (recommended)" on \
XINE "Enable Xine backend" off \
- GSTREAMER "Enable GStreamer backend" off
+ GSTREAMER "Enable GStreamer backend (broken)" off
.include <bsd.port.pre.mk>
@@ -38,13 +36,14 @@ RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
.if defined(WITH_XINE)
LIB_DEPENDS+= xine.1:${PORTSDIR}/multimedia/libxine
.else
-CONFIGURE_ARGS+=--without-xine --without-xcb
+CMAKE_ARGS+= -DWITH_Xine:Bool=Off
.endif
.if defined(WITH_GSTREAMER)
+BROKEN= doesn't compile with GStreamer
USE_GSTREAMER+= yes
.else
-CONFIGURE_ARGS+=--without-gstreamer
+CMAKE_ARGS+= -DWITH_GStreamer:Bool=Off
.endif
.include <bsd.port.post.mk>