aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/tunapie
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/tunapie')
-rw-r--r--multimedia/tunapie/Makefile14
-rw-r--r--multimedia/tunapie/distinfo6
-rw-r--r--multimedia/tunapie/files/patch-install.sh4
-rw-r--r--multimedia/tunapie/files/patch-src-TunerFrame1.py30
-rw-r--r--multimedia/tunapie/files/patch-src-TunerPrefs.py24
-rw-r--r--multimedia/tunapie/files/patch-src-tuner.py39
6 files changed, 31 insertions, 86 deletions
diff --git a/multimedia/tunapie/Makefile b/multimedia/tunapie/Makefile
index bf35c7637d55..30e118f07d46 100644
--- a/multimedia/tunapie/Makefile
+++ b/multimedia/tunapie/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tunapie
-PORTVERSION= 1.3.3.3
+PORTVERSION= 1.4
CATEGORIES= multimedia audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,9 +23,9 @@ USE_WX= 2.6
WX_COMPS= python:run
OPTIONS= ADULT "non-censored TV listings" off \
- XINE "use xine instead of mplayer as default" off \
- AUDACIOUS "use audacious instead of xmms as default" off \
- BEEP_MEDIA_PLAYER "use beep-media-player instead of xmms as default" off
+ XINE "use xine instead of mplayer" off \
+ AUDACIOUS "use audacious instead of xmms" off \
+ BEEP_MEDIA_PLAYER "use beep-media-player instead of xmms" off
MAN1= tunapie.1
PLIST_SUB+= DESKTOPDIR="${DESKTOPDIR:S,^${PREFIX}/,,}"
@@ -46,9 +46,9 @@ post-patch:
-e 's|%%X11BASE%%|${X11BASE}|g' {} ";"
do-install:
- ${MKDIR} ${DATADIR} ${DATADIR}/pixmaps
- ${MKDIR} ${DESKTOPDIR}
- cd ${WRKSRC} && ./install.sh ${ADULT_TVLIST}
+ @${MKDIR} ${DATADIR} ${DATADIR}/pixmaps
+ @${MKDIR} ${DESKTOPDIR}
+ @cd ${WRKSRC} && ./install.sh ${ADULT_TVLIST}
.include <bsd.port.pre.mk>
diff --git a/multimedia/tunapie/distinfo b/multimedia/tunapie/distinfo
index a96529d8f7e7..4c018977a1f5 100644
--- a/multimedia/tunapie/distinfo
+++ b/multimedia/tunapie/distinfo
@@ -1,3 +1,3 @@
-MD5 (tunapie-1.3.3.3.tar.gz) = e5123980d2162157ae6ed1cfef79175e
-SHA256 (tunapie-1.3.3.3.tar.gz) = 7eb34a8e35408390abd943a704b5cfeb19d8c18543b26703adbdb3f0ec4bc8f8
-SIZE (tunapie-1.3.3.3.tar.gz) = 39920
+MD5 (tunapie-1.4.tar.gz) = 6a9a46fa4f3019929f40b71d958db8eb
+SHA256 (tunapie-1.4.tar.gz) = 75db58bc69e30fe1cffb990f7509aba3c091f67dfdc90561e8af49bdf8710290
+SIZE (tunapie-1.4.tar.gz) = 40549
diff --git a/multimedia/tunapie/files/patch-install.sh b/multimedia/tunapie/files/patch-install.sh
index 6ec574d76b40..017548eb1096 100644
--- a/multimedia/tunapie/files/patch-install.sh
+++ b/multimedia/tunapie/files/patch-install.sh
@@ -1,5 +1,5 @@
---- install.sh Thu Dec 21 00:40:35 2006
-+++ install.sh.port Fri Dec 22 23:00:51 2006
+--- install.sh Mon Apr 9 00:35:07 2007
++++ install.sh.port Mon Apr 9 16:25:12 2007
@@ -1,12 +1,10 @@
#!/bin/sh
-if [ "$1" = "--adult" ]; then echo '1'>/etc/tunapie.config
diff --git a/multimedia/tunapie/files/patch-src-TunerFrame1.py b/multimedia/tunapie/files/patch-src-TunerFrame1.py
index c6d8aeb52b3c..f7771098a819 100644
--- a/multimedia/tunapie/files/patch-src-TunerFrame1.py
+++ b/multimedia/tunapie/files/patch-src-TunerFrame1.py
@@ -1,5 +1,5 @@
---- src/TunerFrame1.py Wed Jan 10 00:41:00 2007
-+++ src/TunerFrame1.py.port Mon Jan 29 11:32:44 2007
+--- src/TunerFrame1.py Mon Apr 9 00:35:15 2007
++++ src/TunerFrame1.py.port Mon Apr 9 16:27:24 2007
@@ -130,7 +130,7 @@
self.SetBackgroundColour(wx.Colour(246, 246, 246))
self.SetBackgroundStyle(wx.BG_STYLE_SYSTEM)
@@ -9,29 +9,3 @@
self.SetFont(wx.Font(10, wx.SWISS, wx.NORMAL, wx.NORMAL, False,u'Sans'))
self.SetAutoLayout(True)
self.SetMinSize(wx.Size(770, 410))
-@@ -568,9 +568,13 @@
- self.shoutice=1 #0 is icecast server 1 is shoutcast
- self.maxd=100
- self.newsize=8
-+ self.mediaplayer='%%AUDIOPLAYER%%'
-+ self.videoplayer='%%VIDEOPLAYER%%'
-+ self.term='%%X11BASE%%/bin/xterm'
-+ self.ripper='%%LOCALBASE%%/bin/streamripper -t -u winamp2 -o never'
- self.mediaplayer,self.videoplayer,self.term,self.ripper,self.rdir,\
-- self.shoutice,self.maxd,self.newsize=tuner.readprefs(self.home, self.rdir,\
-- self.shoutice,self.maxd,self.newsize)
-+ self.shoutice,self.maxd,self.newsize=tuner.readprefs(self.home,self.mediaplayer,\
-+ self.videoplayer,self.term,self.ripper,self.rdir,self.shoutice,self.maxd,self.newsize)
- missing_players=[]
- if (commands.getoutput("which "+self.mediaplayer))=="":
- if commands.getoutput("which audacious"):
-@@ -1224,7 +1228,8 @@
- finally:
- dlg.Destroy()
- self.mediaplayer,self.videoplayer,self.term,self.ripper,self.rdir,\
-- self.shoutice,self.maxd,self.newsize=tuner.readprefs(self.home,self.rdir,self.shoutice,self.maxd,self.newsize)
-+ self.shoutice,self.maxd,self.newsize=tuner.readprefs(self.home,self.mediaplayer,
-+ self.videoplayer,self.term,self.ripper,self.rdir,self.shoutice,self.maxd,self.newsize)
- self.setfontsize()
- self.download()
- self.OnRadioradioRadiobutton(1)
diff --git a/multimedia/tunapie/files/patch-src-TunerPrefs.py b/multimedia/tunapie/files/patch-src-TunerPrefs.py
index 7d5d336cad42..e5f1aa709c04 100644
--- a/multimedia/tunapie/files/patch-src-TunerPrefs.py
+++ b/multimedia/tunapie/files/patch-src-TunerPrefs.py
@@ -1,36 +1,36 @@
---- src/TunerPrefs.py Wed Jan 10 00:41:00 2007
-+++ src/TunerPrefs.py.port Sun Jan 28 21:58:34 2007
-@@ -94,7 +94,7 @@
+--- src/TunerPrefs.py Mon Apr 9 00:35:15 2007
++++ src/TunerPrefs.py.port Mon Apr 9 16:31:46 2007
+@@ -96,7 +96,7 @@
self.audiopath = wx.TextCtrl(id=wxID_PREFERENCESAUDIOPATH,
name='audiopath', parent=self, pos=wx.Point(144, 16),
-- size=wx.Size(224, 22), style=0, value='/usr/bin/xmms')
-+ size=wx.Size(224, 22), style=0, value='%%AUDIOPLAYER%%')
+- size=wx.Size(200, 22), style=0, value='/usr/bin/xmms')
++ size=wx.Size(200, 22), style=0, value='%%AUDIOPLAYER%%')
self.audiopath.SetFont(wx.Font(7, 77, wx.NORMAL, wx.NORMAL, False,
u'Sans'))
self.audiopath.SetBackgroundColour(wx.Colour(255, 253, 239))
-@@ -103,7 +103,7 @@
+@@ -105,7 +105,7 @@
self.videopath = wx.TextCtrl(id=wxID_PREFERENCESVIDEOPATH,
name='videopath', parent=self, pos=wx.Point(144, 48),
-- size=wx.Size(216, 22), style=0, value='/usr/bin/mplayer')
-+ size=wx.Size(216, 22), style=0, value='%%VIDEOPLAYER%%')
+- size=wx.Size(200, 22), style=0, value='/usr/bin/mplayer')
++ size=wx.Size(200, 22), style=0, value='%%VIDEOPLAYER%%')
self.videopath.SetFont(wx.Font(7, 77, wx.NORMAL, wx.NORMAL, False,
u'Sans'))
self.videopath.SetBackgroundColour(wx.Colour(255, 253, 239))
-@@ -131,7 +131,7 @@
+@@ -133,7 +133,7 @@
self.termpath = wx.TextCtrl(id=wxID_PREFERENCESTERMPATH,
name='termpath', parent=self, pos=wx.Point(144, 80),
- size=wx.Size(224, 22), style=0,
+ size=wx.Size(200, 22), style=0,
- value='/usr/bin/x-terminal-emulator')
+ value='%%X11BASE%%/bin/xterm')
self.termpath.SetFont(wx.Font(7, wx.SWISS, wx.NORMAL, wx.NORMAL, False,
u'Sans'))
self.termpath.SetBackgroundColour(wx.Colour(255, 253, 239))
-@@ -140,7 +140,7 @@
+@@ -142,7 +142,7 @@
self.rippath = wx.TextCtrl(id=wxID_PREFERENCESRIPPATH, name='rippath',
- parent=self, pos=wx.Point(144, 112), size=wx.Size(224, 22),
+ parent=self, pos=wx.Point(144, 112), size=wx.Size(200, 22),
- style=0, value='/usr/bin/streamripper')
+ style=0, value='%%LOCALBASE%%/bin/streamripper')
self.rippath.SetFont(wx.Font(7, 77, wx.NORMAL, wx.NORMAL, False,
diff --git a/multimedia/tunapie/files/patch-src-tuner.py b/multimedia/tunapie/files/patch-src-tuner.py
index 5f412d584062..422e02b9b76f 100644
--- a/multimedia/tunapie/files/patch-src-tuner.py
+++ b/multimedia/tunapie/files/patch-src-tuner.py
@@ -1,40 +1,11 @@
---- src/tuner.py Wed Jan 10 00:41:00 2007
-+++ src/tuner.py.port Mon Jan 29 11:29:36 2007
-@@ -266,26 +266,27 @@
- preffile.write("max streams to display="+str(int(maxd))+'\n')
- preffile.write("font size="+str(int(fontsize))+'\n')
-
--def readprefs(home,rdir,shoutice,maxd,fontsize):
-+def readprefs(home,media,video,term,rip,rdir,shoutice,maxd,fontsize):
- try: preffile=open(home+'/.tunapie/prefs','r')
- except IOError:
-- return "","","","",rdir,shoutice,maxd,fontsize
-+ return media,video,term,rip,rdir,shoutice,maxd,fontsize
- preferences=preffile.read().split('\n')
-- returnvals=[]
-+ returnvals={'audioplayer':media,'videoplayer':video,'xterm':term,\
-+ 'streamripper':rip,'ripdirectory':rdir,'icecast(0)/shoutcast(1)':shoutice,\
-+ 'max streams to display':maxd,'font size':fontsize}
- for i in preferences:
-- try:returnvals.append(i.split("=")[1])
-- except IndexError: pass
-- if len(returnvals)<8:
-- return media,video,term,rip,rdir,shoutice,maxd,fontsize
-- return(returnvals[0],returnvals[1],returnvals[2],returnvals[3],\
-- returnvals[4],returnvals[5],returnvals[6], returnvals[7])
-+ try:returnvals[i.split("=")[0]]=i.split("=")[1]
-+ except (IndexError,KeyError): pass
-+ return(returnvals['audioplayer'],returnvals['videoplayer'],returnvals['xterm'],\
-+ returnvals['streamripper'],returnvals['ripdirectory'],returnvals['icecast(0)/shoutcast(1)'],\
-+ returnvals['max streams to display'], returnvals['font size'])
-
- def recordselection(terminal,args):
- player=popen2.Popen4(terminal+' '+args)
- return player.pid
+--- src/tuner.py Mon Apr 9 00:35:15 2007
++++ src/tuner.py.port Mon Apr 9 16:33:50 2007
+@@ -290,7 +290,7 @@
+ popen2.Popen4(browser+' '+url)
def adultset():
- try: adultconfig=open('/etc/tunapie.config')
-+ try: adultconfig=open('%%PREFIX%%/etc/tunapie.config')
++ try: adultconfig=open('%%LOCALBASE%%/etc/tunapie.config')
except IOError: return 0
setadult=adultconfig.readline()
return int(setadult)