aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/xfce4-xmms-plugin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/xfce4-xmms-plugin/Makefile')
-rw-r--r--multimedia/xfce4-xmms-plugin/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/multimedia/xfce4-xmms-plugin/Makefile b/multimedia/xfce4-xmms-plugin/Makefile
new file mode 100644
index 000000000000..bb1bc8276987
--- /dev/null
+++ b/multimedia/xfce4-xmms-plugin/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: xfce4-mixer
+# Date created: 2004/05/10
+# Whom: Zahemszky, Gábor <Gabor@Zahemszky.HU>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-xmms-plugin
+PORTVERSION= 0.1.1
+CATEGORIES= multimedia audio xfce
+MASTER_SITES= http://download.berlios.de/xfce-goodies/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= XFce 4 xmms control plugin for xfce4-panel
+
+BUILD_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel \
+ xmms-config:${PORTSDIR}/multimedia/xmms
+LIB_DEPENDS= xfce4util.1:${PORTSDIR}/x11/libxfce4util \
+ xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui \
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
+ startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel \
+ xmms:${PORTSDIR}/multimedia/xmms
+
+USE_BZIP2= yes
+USE_GNOME= gtk20
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER= 15
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
+ CPPFLAGS=-I${LOCALBASE}/include \
+ LIBS=-L${LOCALBASE}/lib
+
+.include <bsd.port.mk>