aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia/xmms-avi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/xmms-avi/Makefile')
-rw-r--r--multimedia/xmms-avi/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/multimedia/xmms-avi/Makefile b/multimedia/xmms-avi/Makefile
new file mode 100644
index 000000000000..ebacbd78c4bc
--- /dev/null
+++ b/multimedia/xmms-avi/Makefile
@@ -0,0 +1,38 @@
+# Ports collection makefile for: xmms-avi
+# Date created: Feb 6 2000
+# Whom: Roman Shterenzon <roman@xpert.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmms-avi
+PORTVERSION= 1.2.2
+CATEGORIES= graphics
+MASTER_SITES= http://www.xmms.org/files/plugins/avi-xmms/ \
+ ftp://ftp.sunet.se/pub/multimedia/xmms/plugins/avi-xmms/ \
+ ftp://ftp.fu-berlin.de/unix/sound/xmms/plugins/avi-xmms/
+DISTNAME= avi-xmms-${PORTVERSION}
+
+MAINTAINER= roman@xpert.com
+
+BUILD_DEPENDS= xmms-config:${PORTSDIR}/audio/xmms
+LIB_DEPENDS= aviplay.0:${PORTSDIR}/graphics/avifile
+RUN_DEPENDS= xmms:${PORTSDIR}/audio/xmms
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+
+ONLY_FOR_ARCHS= i386
+USE_X_PREFIX= yes
+USE_GTK= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+
+pre-patch:
+ @${PERL} -pi.orig -e "s|SDL/SDL.h|SDL11/SDL.h|g" ${WRKSRC}/src/ctrackbar.cpp
+ @${PERL} -pi.orig -e "s|lc_r|pthread|g" ${WRKSRC}/configure
+
+# This is to avoid libtool running ldconfig -m ${X11BASE}/lib/xmms/Input
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/.libs/libavixmms.so ${PREFIX}/lib/xmms/Input
+
+.include <bsd.port.mk>