aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/audacious-plugins/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index f01f40788cb0..b4e11fe293e0 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -132,8 +132,9 @@ PLIST_SUB+= ADPLUGPLUGIN="@comment "
.if !defined(WITHOUT_VORBIS)
LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
-CONFIGURE_ARGS+=--enable-vorbis --enable-flac # it uses an internal flac-lib copy
+CONFIGURE_ARGS+=--enable-vorbis --enable-flac # it uses an internal flac-lib copy
PLIST_SUB+= VORBISPLUGIN=""
+CFLAGS+= -I. -I../libflac -Ilibflac # to not use system flac if it is installed
.else
CONFIGURE_ARGS+=--disable-vorbis --disable-flac
PLIST_SUB+= VORBISPLUGIN="@comment "
@@ -292,11 +293,6 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-I\.\./\.\./\.\.$$|& -I\.\./libflac|' \
- ${WRKSRC}/src/flac/plugin_common/Makefile
-
post-install:
.if defined(WITH_GNOME)
@${ECHO_MSG} ""