aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mencoder/Makefile1
-rw-r--r--multimedia/mplayer/Makefile1
-rw-r--r--multimedia/mplayer/Makefile.options7
3 files changed, 9 insertions, 0 deletions
diff --git a/multimedia/mencoder/Makefile b/multimedia/mencoder/Makefile
index c58559a318d2..34bed878fb8f 100644
--- a/multimedia/mencoder/Makefile
+++ b/multimedia/mencoder/Makefile
@@ -13,6 +13,7 @@ RESTRICTED= Port has restricted dependencies
.include "${.CURDIR}/../mplayer/Makefile.shared"
OPTIONS= DEBUG "Include debug symbols in mencoder's binary" off
+OPTIONS+= BLURAY "Build with libbluray suport" off
OPTIONS+= FONTCONFIG "Enable fontconfig support" off
OPTIONS+= RTCPU "Allow runtime CPU detection" on
OPTIONS+= OCFLAGS "Use optimized compiler flags" on
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 460c704991bc..6b665da78300 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -13,6 +13,7 @@ COMMENT= High performance media player supporting many formats
.include "${.CURDIR}/Makefile.shared"
OPTIONS= DEBUG "Include debug symbols in mplayer's binaries" off
+OPTIONS+= BLURAY "Build with libbluray suport" off
OPTIONS+= RTCPU "Allow runtime CPU detection" on
OPTIONS+= OCFLAGS "Use optimized compiler flags" on
OPTIONS+= IPV6 "Include inet6 network support" on
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index 9d640e03a0fd..5a1b600d6251 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -133,6 +133,13 @@ LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
CONFIGURE_ARGS+= --disable-pulse
.endif
+.if defined(WITH_BLURAY)
+LIB_DEPENDS+= bluray.0:${PORTSDIR}/multimedia/libbluray
+CONFIGURE_ARGS+= --enable-bluray
+.else
+CONFIGURE_ARGS+= --disable-bluray
+.endif
+
.if defined(WITH_SMB)
LIB_DEPENDS+= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
.else