aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/bombono/Makefile2
-rw-r--r--multimedia/gstreamer-plugins/Makefile13
-rw-r--r--multimedia/gstreamer/Makefile6
3 files changed, 8 insertions, 13 deletions
diff --git a/multimedia/bombono/Makefile b/multimedia/bombono/Makefile
index 2a7292e347ca..bdced7316062 100644
--- a/multimedia/bombono/Makefile
+++ b/multimedia/bombono/Makefile
@@ -43,6 +43,8 @@ MANDIR= ${MANPREFIX}/man/man1
post-patch:
@${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/SConstruct
+ @${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
+ ${WRKSRC}/src/mgui/author/gb_devices.c
post-install:
${MKDIR} ${MANDIR}
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index b8a78fc4392b..f1c4c7aac6d8 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: gstreamer plugins
-# Date created: Wed Jul 10 23:38:01 UTC 2002
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-#
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/multimedia/gstreamer-plugins/Makefile,v 1.125 2010/03/16 19:33:10 mezz Exp $
-#
PORTNAME= gstreamer
PORTVERSION?= ${BASE_PORTVERSION}
@@ -25,8 +21,8 @@ COMMENT?= GStreamer written collection of plugins handling several media types
BUILD_DEPENDS+= v4l_compat>=1.0.20110720:${PORTSDIR}/multimedia/v4l_compat \
gstreamer>=0.10.36:${PORTSDIR}/multimedia/gstreamer \
orc>=0.4.14:${PORTSDIR}/devel/orc
-LIB_DEPENDS+= gstreamer-0.10.0:${PORTSDIR}/multimedia/gstreamer \
- orc-0.4.0:${PORTSDIR}/devel/orc
+LIB_DEPENDS+= gstreamer-0.10:${PORTSDIR}/multimedia/gstreamer \
+ orc-0.4:${PORTSDIR}/devel/orc
CFLAGS:= ${CFLAGS} -O2 -Wno-format
@@ -50,7 +46,8 @@ VERSION= ${GST_VERSION}
WANT_GSTREAMER= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME+= gnomehack pkgconfig ltverhack ltasneededhack
+USE_GNOME+= gnomehack ltverhack ltasneededhack
+USE_PKGCONFIG= build
USE_AUTOTOOLS= libtool
GST_PLUGIN?= base
diff --git a/multimedia/gstreamer/Makefile b/multimedia/gstreamer/Makefile
index f1e95d5a1e3e..d7113454e069 100644
--- a/multimedia/gstreamer/Makefile
+++ b/multimedia/gstreamer/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: gstreamer
-# Date created: Tue Jul 9 20:24:02 UTC 2002
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-#
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/multimedia/gstreamer/Makefile,v 1.74 2010/03/09 10:11:45 kwm Exp $
-#
PORTNAME= gstreamer
PORTVERSION= 0.10.36