aboutsummaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/vlc-devel/Makefile4
-rw-r--r--multimedia/vlc-devel/files/patch-wxgtk2810
2 files changed, 12 insertions, 2 deletions
diff --git a/multimedia/vlc-devel/Makefile b/multimedia/vlc-devel/Makefile
index d7c1948989a3..5c44fa47a7df 100644
--- a/multimedia/vlc-devel/Makefile
+++ b/multimedia/vlc-devel/Makefile
@@ -10,7 +10,7 @@
PORTNAME= vlc
DISTVERSION= 0.8.6a
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 2
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/vlc/${DISTVERSION}/ \
@@ -182,7 +182,7 @@ CONFIGURE_ARGS+=--disable-loader
.endif
.if !defined(WITHOUT_WXGTK)
-USE_WX= 2.6
+USE_WX= 2.8
WX_UNICODE= yes
CONFIGURE_ARGS+=--enable-wxwidgets
.else
diff --git a/multimedia/vlc-devel/files/patch-wxgtk28 b/multimedia/vlc-devel/files/patch-wxgtk28
new file mode 100644
index 000000000000..adcb742a7573
--- /dev/null
+++ b/multimedia/vlc-devel/files/patch-wxgtk28
@@ -0,0 +1,10 @@
+--- modules/gui/wxwidgets/dialogs.cpp
++++ modules/gui/wxwidgets/dialogs.cpp
+@@ -380,7 +380,7 @@
+ {
+ p_file_generic_dialog->SetMessage( wxU(p_arg->psz_title) );
+ p_file_generic_dialog->SetWildcard( wxU(p_arg->psz_extensions) );
+- p_file_generic_dialog->SetStyle( (p_arg->b_save ? wxSAVE : wxOPEN) |
++ p_file_generic_dialog->SetWindowStyle( (p_arg->b_save ? wxSAVE : wxOPEN) |
+ (p_arg->b_multiple ? wxMULTIPLE:0) );
+ }