aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/centericq
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/centericq')
-rw-r--r--net-im/centericq/Makefile15
-rw-r--r--net-im/centericq/distinfo2
-rw-r--r--net-im/centericq/files/patch-aa36
-rw-r--r--net-im/centericq/files/patch-configure14
-rw-r--r--net-im/centericq/pkg-plist3
5 files changed, 20 insertions, 50 deletions
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
index 616a78217202..c62dda5db477 100644
--- a/net-im/centericq/Makefile
+++ b/net-im/centericq/Makefile
@@ -7,18 +7,20 @@
#
PORTNAME= centericq
-PORTVERSION= 4.2.1
+PORTVERSION= 4.5.0
CATEGORIES= net
MASTER_SITES= http://konst.org.ua/download/
MAINTAINER= ijliao@FreeBSD.org
-LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext \
+ sigc.1:${PORTSDIR}/devel/libsigc++
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl"
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lintl"
+CONFIGURE_ARGS= --without-included-gettext
MAN1= centericq.1
@@ -30,4 +32,9 @@ CFLAGS+= -nostdinc -I${LOCALBASE}/include/ncurses \
-I${LOCALBASE}/include -I/usr/include
.endif
+post-patch:
+ @${PERL} -pi -e "s,\@mandir\@,\@mandir\@/man1,g ; \
+ s,\$\(pkgdatadir\),\$\(mandir\),g ; \
+ s,intl,,g" ${WRKSRC}/Makefile.in
+
.include <bsd.port.post.mk>
diff --git a/net-im/centericq/distinfo b/net-im/centericq/distinfo
index a7746d50ca8c..b28576e3fd6d 100644
--- a/net-im/centericq/distinfo
+++ b/net-im/centericq/distinfo
@@ -1 +1 @@
-MD5 (centericq-4.2.1.tar.gz) = 73e30600f9a1250abbc06bc38f88244a
+MD5 (centericq-4.5.0.tar.gz) = 5840ffa2346cd77703f10d96ce043e38
diff --git a/net-im/centericq/files/patch-aa b/net-im/centericq/files/patch-aa
deleted file mode 100644
index ba3c9d0b01df..000000000000
--- a/net-im/centericq/files/patch-aa
+++ /dev/null
@@ -1,36 +0,0 @@
---- icqlib-1.2/cyrillic.c.orig Mon Jul 2 09:38:19 2001
-+++ icqlib-1.2/cyrillic.c Mon Jul 2 09:41:54 2001
-@@ -30,8 +30,8 @@
-
- BYTE kw[] = {128,129,130,131,132,133,134,135,136,137,138,139,140,141,142,143,
- 144,145,146,147,148,149,150,151,152,153,154,155,156,157,158,159,
-- 160,161,162,184,164,165,166,167,168,169,170,171,172,173,174,175,
-- 176,177,178,168,180,181,182,183,184,185,186,187,188,189,190,191,
-+ 160,161,162,184,186,165,179,191,168,169,170,171,172,180,174,175,
-+ 176,177,178,168,170,181,178,175,184,185,170,187,188,165,190,169,
- 254,224,225,246,228,229,244,227,245,232,233,234,235,236,237,238,
- 239,255,240,241,242,243,230,226,252,251,231,248,253,249,247,250,
- 222,192,193,214,196,197,212,195,213,200,201,202,203,204,205,206,
-@@ -39,8 +39,8 @@
-
- BYTE wk[] = {128,129,130,131,132,133,134,135,136,137,138,139,140,141,142,143,
- 144,145,146,147,148,149,150,151,152,153,154,155,156,157,158,159,
-- 160,161,162,163,164,165,166,167,179,169,170,171,172,173,174,175,
-- 176,177,178,179,180,181,182,183,163,185,186,187,188,189,190,191,
-+ 160,161,162,163,164,189,166,167,179,191,180,171,172,173,174,183,
-+ 176,177,182,166,173,181,182,183,163,185,164,187,188,189,190,167,
- 225,226,247,231,228,229,246,250,233,234,235,236,237,238,239,240,
- 242,243,244,245,230,232,227,254,251,253,255,249,248,252,224,241,
- 193,194,215,199,196,197,214,218,201,202,203,204,205,206,207,208,
-@@ -53,6 +53,11 @@
- This function will convert string from windows 1251 to koi8
- or from koi8 to windows 1251.
- Andrew Frolov dron@ilm.net
-+*********************************************************
-+Fixed for win1251<->koi8-u convertion. Now all Ukrainian letters
-+ are transcoded!
-+Kunytsa Olexander aka Cawko Xakep UKMA InterNet Project
-+xakep@snark.ukma.kiev.ua #19983820
- *********************************************************/
-
- extern int icq_Russian;
diff --git a/net-im/centericq/files/patch-configure b/net-im/centericq/files/patch-configure
index 502ecc91cba0..24ff718af2df 100644
--- a/net-im/centericq/files/patch-configure
+++ b/net-im/centericq/files/patch-configure
@@ -1,11 +1,11 @@
---- configure.orig Mon Oct 8 04:22:30 2001
-+++ configure Mon Oct 8 04:22:48 2001
-@@ -1224,7 +1224,7 @@
- fi
+--- configure.orig Sun Dec 16 18:09:46 2001
++++ configure Sun Dec 16 18:10:13 2001
+@@ -1935,7 +1935,7 @@
fi
+
-ALL_LINGUAS="zh_TW.Big5 ru ro pt_BR pl it hu es de cs"
+ALL_LINGUAS="zh_TW.Big5 ru ro pt_BR pl it hu es de cs uk"
- echo $ac_n "checking how to run the C preprocessor""... $ac_c" 1>&6
- echo "configure:1230: checking how to run the C preprocessor" >&5
- # On Suns, sometimes $CPP names a directory.
+ echo $ac_n "checking for POSIXized ISC""... $ac_c" 1>&6
+ echo "configure:1941: checking for POSIXized ISC" >&5
+ if test -d /etc/conf/kconfig.d &&
diff --git a/net-im/centericq/pkg-plist b/net-im/centericq/pkg-plist
index c8ab6f52c464..b26aa80aee89 100644
--- a/net-im/centericq/pkg-plist
+++ b/net-im/centericq/pkg-plist
@@ -1,11 +1,10 @@
bin/centericq
bin/cicqconv
bin/cicqsync
-share/centericq/cont.wav
share/centericq/email.wav
-share/centericq/file.wav
share/centericq/msg.wav
share/centericq/online.wav
+share/centericq/sms.wav
share/centericq/url.wav
share/locale/cs/LC_MESSAGES/centericq.mo
share/locale/de/LC_MESSAGES/centericq.mo