aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/centerim-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/centerim-devel/Makefile')
-rw-r--r--net-im/centerim-devel/Makefile69
1 files changed, 32 insertions, 37 deletions
diff --git a/net-im/centerim-devel/Makefile b/net-im/centerim-devel/Makefile
index 888513ec7cee..19353cd278c1 100644
--- a/net-im/centerim-devel/Makefile
+++ b/net-im/centerim-devel/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: centerim
-# Date created: 2006-03-14
-# Whom: Frank Altpeter <frank@altpeter.de>
-#
+# Created by: Frank Altpeter <frank@altpeter.de>
# $FreeBSD$
-#
PORTNAME= centerim
PORTVERSION= 4.22.10.11
@@ -14,7 +9,7 @@ MASTER_SITES= http://www.centerim.org/download/mobshots/ \
PKGNAMESUFFIX= -devel
MAINTAINER= frank@altpeter.de
-COMMENT= A text mode menu- and window-driven IM interface
+COMMENT= Text mode menu- and window-driven IM interface
LICENSE= GPLv2
@@ -29,64 +24,64 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ssl --with-openssl
CONFLICTS= centericq-[0-9]* centerim-[0-9]*
-OPTIONS= NLS "Native Language Support" on \
- MULTIBYTE "Multibyte Support" on \
- FRIBIDI "Fribidi Support" on \
- MSN "Support for MSN Protocol" on \
- YAHOO "Support for Yahoo! Messenger Protocol" on \
- AIM "Support for AOL's Instant Messenger Protocol" on \
- IRC "Support for IRC Protocol" on \
- JABBER "Support for Jabber Protocol" on \
- GPGME "Support for PGP encrypted Jabber messages" on \
- RSS "Support for RSS" on \
- LJ "Support for LiveJournal" on \
- GG "Support for Gadu-Gadu Protocol" on
+OPTIONS_DEFINE= NLS MULTIBYTE FRIBIDI MSN YAHOO AIM IRC JABBER GPGME RSS LJ GG
+FRIBIDI_DESC= Fribidi Support
+MSN_DESC= MSN Protocol
+YAHOO_DESC= Yahoo! Messenger Protocol
+AIM_DESC= AOL's Instant Messenger Protocol
+IRC_DESC= IRC Protocol
+GPGME_DESC= PGP encrypted Jabber messages
+RSS_DESC= RSS Support
+LJ_DESC= LiveJournal Support
+GG_DESC= Gadu-Gadu Protocol Support
+
+OPTIONS_DEFAULT= MULTIBYTE FRIBIDI MSN YAHOO AIM IRC JABBER GPGME RSS LJ GG
MAN1= cimconv.1 centerim.1
PORTDOCS= FAQ README
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
.endif
-.if defined(WITH_MULTIBYTE)
+.if ${PORT_OPTIONS:MMULTIBYTE}
CONFIGURE_ARGS+= --enable-locales-fix
.endif
-.if defined(WITH_FRIBIDI)
+.if ${PORT_OPTIONS:MFRIBIDI}
LIB_DEPENDS+= fribidi.3:${PORTSDIR}/converters/fribidi
CONFIGURE_ARGS+= --with-fribidi
.endif
-.if !defined(WITH_MSN)
+.if ! ${PORT_OPTIONS:MMSN}
CONFIGURE_ARGS+= --disable-msn
.endif
-.if !defined(WITH_YAHOO)
+.if ! ${PORT_OPTIONS:MYAHOO}
CONFIGURE_ARGS+= --disable-yahoo
.endif
-.if !defined(WITH_AIM)
+.if ! ${PORT_OPTIONS:MAIM}
CONFIGURE_ARGS+= --disable-aim
.endif
-.if !defined(WITH_IRC)
+.if ! ${PORT_OPTIONS:MIRC}
CONFIGURE_ARGS+= --disable-irc
.endif
-.if !defined(WITH_JABBER)
+.if ! ${PORT_OPTIONS:MJABBER}
CONFIGURE_ARGS+= --disable-jabber
.else
.endif
-.if !defined(WITH_GPGME)
+.if ! ${PORT_OPTIONS:MGPGME}
CONFIGURE_ARGS+= --without-gpgme
.else
LIB_DEPENDS+= gpgme.19:${PORTSDIR}/security/gpgme
@@ -94,15 +89,15 @@ LIB_DEPENDS+= gpgme.19:${PORTSDIR}/security/gpgme
CONFIGURE_ARGS+= --with-ssl
.endif
-.if !defined(WITH_RSS)
+.if ! ${PORT_OPTIONS:MRSS}
CONFIGURE_ARGS+= --disable-rss
.endif
-.if !defined(WITH_LJ)
+.if ! ${PORT_OPTIONS:MLJ}
CONFIGURE_ARGS+= --disable-lj
.endif
-.if !defined(WITH_GG)
+.if ! ${PORT_OPTIONS:MGG}
CONFIGURE_ARGS+= --disable-gg
.else
LIB_DEPENDS+= gadu.3:${PORTSDIR}/polish/ekg
@@ -113,10 +108,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|/var/run/screen|/tmp/screens|' \
${WRKSRC}/src/icqconf.cc
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}
@(cd ${WRKSRC} ; ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>