aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/empathy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/empathy/Makefile')
-rw-r--r--net-im/empathy/Makefile39
1 files changed, 35 insertions, 4 deletions
diff --git a/net-im/empathy/Makefile b/net-im/empathy/Makefile
index c4b20af7750e..e61022503443 100644
--- a/net-im/empathy/Makefile
+++ b/net-im/empathy/Makefile
@@ -3,11 +3,10 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/net-im/empathy/Makefile,v 1.5 2008/03/10 13:39:43 ahze Exp $
+# $MCom: ports/net-im/empathy/Makefile,v 1.16 2008/10/20 23:38:20 kwm Exp $
PORTNAME= empathy
-PORTVERSION= 0.22.1
-PORTREVISION= 2
+PORTVERSION= 2.24.1
CATEGORIES= net-im gnome
MASTER_SITES= GNOME
@@ -21,11 +20,13 @@ LIB_DEPENDS= missioncontrol-server.1:${PORTSDIR}/net-im/telepathy-mission-contro
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
USE_GMAKE= yes
+USE_BZIP2= yes
USE_GETTEXT= yes
USE_LDCONFIG= yes
USE_GNOME= evolutiondataserver gnomehack gnomeprefix pygtk2 ltverhack \
gnomepanel
USE_AUTOTOOLS= libtool:15
+INSTALLS_OMF= yes
INSTALLS_ICONS= yes
USE_PYTHON= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -33,8 +34,38 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GCONF_SCHEMAS= GNOME_Megaphone_Applet.schemas empathy.schemas
+MAN1= empathy.1
+
+OPTIONS= JABBER "Enable jabber (XMPP) client support" on \
+ MSN "Enable MSN client support" on \
+ IRC "Enable IRC client support" on \
+ SALUT "Enable link-local (serverless) XMPP support" off \
+ HAZE "Enable libpurple protocol integration" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_JABBER)
+RUN_DEPENDS+= ${LOCALBASE}/libexec/telepathy-gabble:${PORTSDIR}/net-im/telepathy-gabble
+.endif
+
+.if defined(WITH_MSN)
+RUN_DEPENDS+= ${LOCALBASE}/libexec/telepathy-butterfly:${PORTSDIR}/net-im/telepathy-butterfly
+.endif
+
+.if defined(WITH_IRC)
+RUN_DEPENDS+= telepathy-idle:${PORTSDIR}/net-im/telepathy-idle
+.endif
+
+.if !defined(WITHOUT_SALUT)
+RUN_DEPENDS+= ${LOCALBASE}/libexec/telepathy-salut:${PORTSDIR}/net-im/telepathy-salut
+.endif
+
+.if !defined(WITHOUT_HAZE)
+RUN_DEPENDS+= ${LOCALBASE}/libexec/telepathy-haze:${PORTSDIR}/net-im/telepathy-haze
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|$${datadir}/gtk-doc/html|${DOCSDIR}|' \
${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>