aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/icmpchat/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/icmpchat/Makefile')
-rw-r--r--net-im/icmpchat/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/net-im/icmpchat/Makefile b/net-im/icmpchat/Makefile
index 4ba770d27e6c..d21df3d4ee3b 100644
--- a/net-im/icmpchat/Makefile
+++ b/net-im/icmpchat/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: icmpchat
+# New ports collection makefile for: ICMP-Chat
# Date created: 8 October 2002
-# Whom: mwest@uct.ac.za
+# Whom: Matthew West <mwest@uct.ac.za>
#
# $FreeBSD$
#
@@ -12,17 +12,15 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= icmpchat
MAINTAINER= ports@FreeBSD.org
-COMMENT= Simple console-based chat that uses the ICMP protocol
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
+COMMENT= Simple console-based chat that uses ICMP protocol
pre-patch:
@${REINPLACE_CMD} -e 's|-O2 -Wall -pedantic|${CFLAGS}|;\
s|= gcc|?= gcc|;s|default|all|' ${WRKSRC}/Makefile
+# Fix for GCC 4.2
+ @${REINPLACE_CMD} -e \
+ 's|((uint8_t \*) data) +=|data += sizeof(uint8_t *) *|' \
+ ${WRKSRC}/sha256.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/icmpchat ${PREFIX}/bin
@@ -35,4 +33,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/Todo ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>