aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/libnice/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/libnice/Makefile')
-rw-r--r--net-im/libnice/Makefile35
1 files changed, 27 insertions, 8 deletions
diff --git a/net-im/libnice/Makefile b/net-im/libnice/Makefile
index 95cbb8752498..a9cd612eb92d 100644
--- a/net-im/libnice/Makefile
+++ b/net-im/libnice/Makefile
@@ -1,13 +1,12 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom$
+# $MCom: ports/trunk/net-im/libnice/Makefile 19801 2014-08-13 09:46:10Z gusi $
PORTNAME= libnice
-PORTVERSION= 0.1.3
+PORTVERSION= 0.1.7
PORTREVISION= 1
CATEGORIES= net-im devel
-MASTER_SITES= http://nice.freedesktop.org/releases/ \
- http://miwibox.org/distfiles/
+MASTER_SITES= http://nice.freedesktop.org/releases/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Library and transmitter that implements ICE-19
@@ -15,17 +14,37 @@ COMMENT= Library and transmitter that implements ICE-19
USES= gettext gmake libtool pathfix pkgconfig
USE_LDCONFIG= yes
USE_GNOME= glib20
-USE_GSTREAMER= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-gstreamer --with-gstreamer-0.10
CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_GETIFADDRS
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
+.if !defined(LIBNICE_SLAVE)
+OPTIONS_DEFINE= GUPNP
+GUPNP_DESC= UPnP IGD port mapping support
+GUPNP_LIB_DEPENDS+= libgupnp-igd-1.0.so:${PORTSDIR}/net/gupnp-igd
+GUPNP_CONFIGURE_ENABLE= gupnp
+.endif
+
+#.include <bsd.port.options.mk>
+
+.if defined(LIBNICE_SLAVE)
+. if ${LIBNICE_SLAVE}==gstreamer010
+USE_GSTREAMER= yes
+CONFIGURE_ARGS+=--without-gstreamer --with-gstreamer-0.10
+. endif
+. if ${LIBNICE_SLAVE}==gstreamer1
+USE_GSTREAMER1= yes
+CONFIGURE_ARGS+=--with-gstreamer --without-gstreamer-0.10
+. endif
+.else
+CONFIGURE_ARGS= --without-gstreamer --without-gstreamer-0.10
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|-Wno-missing-field-initializers|#|g'
- @${REINPLACE_CMD} -e 's|-Wno-missing-field-initializers|#|g' \
- ${WRKSRC}/common.mk
+ @${REINPLACE_CMD} -e 's|-Werror||g' ${WRKSRC}/configure
.include <bsd.port.mk>
+