aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/libpurple/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/libpurple/Makefile')
-rw-r--r--net-im/libpurple/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index f49ad400b788..9c671c0e20ba 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -4,7 +4,7 @@
PORTNAME?= libpurple
PORTVERSION= 2.10.9
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= net-im
MASTER_SITES= SF/pidgin/Pidgin/${PORTVERSION}
DISTNAME= pidgin-${PORTVERSION}
@@ -12,8 +12,7 @@ DISTNAME= pidgin-${PORTVERSION}
MAINTAINER?= marcus@FreeBSD.org
COMMENT?= Backend library for the Pidgin multi-protocol messaging client
-USE_BZIP2= yes
-USES= gmake pkgconfig pathfix
+USES= gmake libtool pathfix pkgconfig tar:bzip2
USE_GNOME?= gnomeprefix intlhack glib20 libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS?=--disable-gtkui \
@@ -336,7 +335,7 @@ post-patch:
${WRKSRC}/libpurple/purple-url-handler
.if defined(PIDGIN_SLAVE)
@${FIND} ${BUILD_WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
- 's|[$$][(]top_builddir[)]/libpurple/libpurple.la|${LOCALBASE}/lib/libpurple.la|g'
+ 's|$$(top_builddir)/libpurple/libpurple.la|-lpurple|'
.endif
@${FIND} ${WRKSRC} -type f | ${XARGS} ${TOUCH}