aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/loudmouth/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/loudmouth/Makefile')
-rw-r--r--net-im/loudmouth/Makefile23
1 files changed, 16 insertions, 7 deletions
diff --git a/net-im/loudmouth/Makefile b/net-im/loudmouth/Makefile
index e703db2d5879..dad52ac49bce 100644
--- a/net-im/loudmouth/Makefile
+++ b/net-im/loudmouth/Makefile
@@ -23,19 +23,28 @@ USE_GETTEXT= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
USE_GNOME= gnomehack glib20 ltverhack
-CONFIGURE_ARGS= --disable-gtk-doc
+CONFIGURE_ARGS= --disable-gtk-doc --enable-debug=no
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-Wl,-Bsymbolic -L${LOCALBASE}/lib"
-OPTIONS= GNUTLS "Enable SSL (via GnuTLS) support" on
+OPTIONS= GNUTLS "Enable SSL (via GnuTLS) support" on \
+ OPENSSL "Enable SSL (via OpenSSL) support" off
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_GNUTLS)
-LIB_DEPENDS+= gnutls.40:${PORTSDIR}/security/gnutls
-RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
-.else
-CONFIGURE_ARGS+= --without-ssl
+.if defined(WITH_GNUTLS)
+LIB_DEPENDS+= gnutls.40:${PORTSDIR}/security/gnutls
+RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+.endif
+
+.if defined(WITH_OPENSSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--with-ssl=openssl
+RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+.endif
+
+.if !defined(WITH_GNUTLS) && !defined(WITH_OPENSSL)
+CONFIGURE_ARGS+=--without-ssl
.endif
post-patch: