aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/mercury
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/mercury')
-rw-r--r--net-im/mercury/Makefile9
-rw-r--r--net-im/mercury/distinfo4
-rw-r--r--net-im/mercury/files/Mercury_Messenger.in8
3 files changed, 13 insertions, 8 deletions
diff --git a/net-im/mercury/Makefile b/net-im/mercury/Makefile
index 110bf618c714..ac02bfc083bb 100644
--- a/net-im/mercury/Makefile
+++ b/net-im/mercury/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mercury
-DISTVERSION= 1709_RC6b
+DISTVERSION= 1709_RC8
CATEGORIES= net java
MASTER_SITES= http://download.mercury.to/ \
${MASTER_SITE_LOCAL}
@@ -18,15 +18,18 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= thierry@FreeBSD.org
COMMENT= Java Based MSN client
-RUN_DEPENDS= jmfinit:${PORTSDIR}/java/jmf
+RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper \
+ jmfinit:${PORTSDIR}/java/jmf
USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.4+
NO_BUILD= yes
+JMF_JARS= customizer jmf mediaplayer multiplayer
+
SUB_FILES= Mercury_Messenger
-SUB_LIST= JAVA=${JAVA}
+SUB_LIST= JAVA_VERSION="${JAVA_VERSION}" JMF_JARS="${JMF_JARS:S|$|.jar|}"
LINSTDIR?= share/Mercury
INSTDIR= ${PREFIX}/${LINSTDIR}
diff --git a/net-im/mercury/distinfo b/net-im/mercury/distinfo
index 9c172e01e0fa..9da575002f2b 100644
--- a/net-im/mercury/distinfo
+++ b/net-im/mercury/distinfo
@@ -1,2 +1,2 @@
-MD5 (mercury/1709_RC6b.zip) = caad8b76f57d505c6e1640855650046b
-SIZE (mercury/1709_RC6b.zip) = 5109978
+MD5 (mercury/1709_RC8.zip) = 51fc8ac2f1635b4fca7bbd03823bc0d3
+SIZE (mercury/1709_RC8.zip) = 5100494
diff --git a/net-im/mercury/files/Mercury_Messenger.in b/net-im/mercury/files/Mercury_Messenger.in
index 2e5f63f48221..8322bd859ce5 100644
--- a/net-im/mercury/files/Mercury_Messenger.in
+++ b/net-im/mercury/files/Mercury_Messenger.in
@@ -1,4 +1,6 @@
-#!/bin/sh
+#! /bin/sh
+# $FreeBSD$
+
MERCURY_INSTALL_PATH="%%PREFIX%%/share/Mercury"
JMF_INSTALL_PATH="%%JAVALIBDIR%%"
cd $MERCURY_INSTALL_PATH
@@ -7,8 +9,8 @@ for file in `ls $MERCURY_INSTALL_PATH/lib`
do
classpath="$MERCURY_INSTALL_PATH/lib/$file:$classpath"
done
-for file in `ls $JMF_INSTALL_PATH`
+for file in %%JMF_JARS%%
do
classpath="$JMF_INSTALL_PATH/$file:$classpath"
done
-%%JAVA%% -classpath $classpath com.dMSN.Main
+JAVA_VERSION=%%JAVA_VERSION%% %%LOCALBASE%%/bin/java -classpath $classpath com.dMSN.Main
work.thierry2004-04-143-72/+17 * Let Makefile.common do the work.thierry2004-04-143-13/+6 * - Fix regression when using gcc-objc-3.2dinoex2004-04-141-2/+4 * Update to 1.2.2. For a list of what's changed, see:marcus2004-04-148-63/+45 * Attempt to fix build on amd64 by using va_copyarved2004-04-143-4/+28 * Update to 1.1.0 to fix build problems on amd64arved2004-04-143-8/+5 * Attempt to fix build on amd64 by using va_copyarved2004-04-142-4/+15 * Attempt to fix build on amd64 by using va_copyarved2004-04-142-4/+15 * Attempt to fix build by using va_copy on amd64arved2004-04-142-4/+14 * - revert to build without libobjcdinoex2004-04-131-1/+4 * Add missing filekris2004-04-133-0/+3 * Add missing @dirrmkris2004-04-131-0/+1 * Make the TCL_VER(sion) a knob, rather than hardcoding the 8.3.mi2004-04-132-9/+8 * not listed on sourceforgeijliao2004-04-125-26/+0 * This only works on architectures where sizeof(int) == sizeof(void*), i.e.kris2004-04-121-1/+1 * BROKEN on sparc64: Build failskris2004-04-122-2/+14 * BROKEN: Does not buildkris2004-04-121-0/+2 * BROKEN: Build failskris2004-04-121-0/+2 * fix build on -stableijliao2004-04-125-2/+66 * BROKEN: This is also broken on i386kris2004-04-121-6/+2 * BROKEN: Does not compilekris2004-04-121-0/+2 * BROKEN with perl < 5.8: Does not compilekris2004-04-111-1/+7 * As announced 2 months ago, remove these deprecated or broken ports.kris2004-04-1117-280/+0 * * Use lthackmarcus2004-04-114-24/+12 * Ooops... Garbaged makefile was committed. I'm very sorry about this.lev2004-04-114-28/+0 * Unbreak port after last ade's commit.lev2004-04-118-88/+112 * Tidy up whitespace.trevor2004-04-1131-55/+53 * Cram into 80 columns by 24 rows.trevor2004-04-116-345/+66 * Fix build broken by GTK 2.4 update.bland2004-04-111-0/+5 * Trim whitespace.trevor2004-04-1113-15/+7 * Update port: devel/pear-XML_Serializer - update to version 0.9.1.thierry2004-04-103-7/+10 * Update port: devel/pear-XML_Util - update to version 0.5.2.thierry2004-04-103-26/+5 * Remove part or post-patch wich is not longer required.bland2004-04-101-2/+0 * - Update to 0.42sergei2004-04-103-4/+5 * Fix build: DDD builds with either GCC 3.1 or GCC 3.2. Use 3.1 iflioux2004-04-101-2/+9 * - Add a vendor patch that corrects a problem with sendfile(2)krion2004-04-102-0/+20 * - Update the Ruby/GNOME2 suite to 0.9.1.knu2004-04-0910-14/+14 * update to 0.2.7oliver2004-04-092-3/+3 * Update to 5.4.trevor2004-04-096-162/+488 * Fix grammar and spalling. List home page.trevor2004-04-092-4/+8 * Fix threading issues with libc_r on 5.2.1 by making sure to pass -lc_r tomarcus2004-04-092-14/+17 * Add haddock to BUILD_DEPENDS do not replace BUILD_DEPENDS with haddock!obraun2004-04-091-1/+1 * - use INFOdinoex2004-04-082-3/+1 * Correct last commit.trevor2004-04-081-1/+1 * Update to 0.16.15.trevor2004-04-082-6/+4 * Update to 2.6.0.marcus2004-04-085-58/+7 * Add missing BUILD_DEPENDS on kdesdk3.lofi2004-04-071-1/+2 * - Reintroduce .la file since they aren't "librerias non grata"clement2004-04-076-39/+3 * Drop maintainership.trevor2004-04-071-1/+1 * Shorten comment. Drop maintainership.trevor2004-04-071-2/+2 * add itext 1.02bijliao2004-04-074-0/+44 * Use PLIST_FILES.trevor2004-04-071-6/+3 * Point users to the 2.4-to-2.6 upgrade FAQ instead of the devel FAQ.marcus2004-04-071-1/+1 * Avoid GnuTLS support at all costs.marcus2004-04-074-20/+22 * BROKEN: Unfetchablekris2004-04-071-0/+2 * Quiet the warnings here as I hunt the tcl-trf miscompilations with -Werror.mi2004-04-071-0/+51 * Fix packing list when NOPORTDOCS is set.trevor2004-04-061-0/+1 * - Update to version 1.0.4krion2004-04-064-33/+3 * Bugfixes for new devices.lev2004-04-062-3/+3 * Some bugfixeslev2004-04-064-6/+6 * Fix situation with info files.lev2004-04-062-40/+11 * echo -> ${ECHO}, remove USE_GETTEXT at all.lev2004-04-061-4/+3 * Fix *.info installtion. Unbroke.lev2004-04-062-28/+11 * add dprog 0.3.1ijliao2004-04-0611-0/+125 * Update the dependency on tcllib from 1.4 to 1.6. May be, tcllib shouldmi2004-04-061-1/+1 * Finish removing this port.kris2004-04-053-48/+0 * update to 0.2.6oliver2004-04-053-5/+5 * - Update pkg-descr to reflect realitysergei2004-04-051-5/+7 * Add p5-Net-LibIDN 0.04, this module provides access to the libidnerwin2004-04-055-0/+46 * Add p5-File-Type 0.20, determine file type using magic.erwin2004-04-055-0/+46 * Whoops, something got fubar'd. Put these versions back to 2.6.0.marcus2004-04-051-1/+1 * Update to 2.0.7.marcus2004-04-052-4/+3 * Fix some known compatibility problems with GNOME 2.6.marcus2004-04-051-1/+1 * Add libglade-java, Java wrappers around libglade-2.4.marcus2004-04-057-0/+117 * Add libgconf-java, Java wrappers around GConf 2.4.marcus2004-04-058-0/+127 * Remove gnomevfs-extras now that it has been integrated into gnomevfs2.marcus2004-04-055-84/+0 * Chase the glib20 update, and bump all affected ports' PORTREVISIONs.marcus2004-04-0542-37/+42 * Presenting GNOME 2.6.0. The FreeBSD GNOME Team feels this our best releasemarcus2004-04-0588-1447/+1638 * Reset two missed ports back to WANT_AUTO* -- the other one mentioned,ade2004-04-054-4/+4 * Add pear-XML_SVG 0.0.3, PEAR object-oriented API for building SVGthierry2004-04-054-0/+29 * Unbreak. Builds, installs fine on fresh current. Disable the parallelmi2004-04-051-5/+1 * Make the wish-version selectable. Default to 8.4. Update master-site, and WWW.mi2004-04-052-5/+7 * Upgrade from 1.4.1 to 1.5.0, released on February 17. Turn on self-tests.mi2004-04-054-16/+27 * Update to 1.05erwin2004-04-052-3/+3 * Update to 1.22erwin2004-04-052-3/+3 * Update to version 1.3.1markus2004-04-053-4/+15 * Add pear-VFS 0.0.4, PEAR Virtual File System API.thierry2004-04-054-0/+50 * Apache Avalon provides a complete platform for component programming includinglinimon2004-04-054-0/+72 * Hook up gdb6 to the build.obrien2004-04-041-0/+1 * Somehow, pkg-descr from another port was added. Replace with aerwin2004-04-041-10/+7 * BROKEN on !i386 and !alpha (gcc internal compiler error); mark IGNOREkris2004-04-041-1/+9 * Upgrade from 1.4 to 1.6. Unreak on Alpha for the time being.mi2004-04-043-12/+45 * . Use MASTER_SITE_APACHE_JAKARTA, which should greatly improve theglewis2004-04-041-1/+2 * BROKEN on amd64: Coredump during buildkris2004-04-031-1/+7 * BROKEN on !i386: Does not compilekris2004-04-031-0/+5 * BROKEN on amd64: Configure failskris2004-04-031-1/+7 * BROKEN on amd64: Does not buildkris2004-04-033-3/+21 * Upgrade to v5.5.4.jkoshy2004-04-032-3/+3 * Log:znerd2004-04-033-23/+22 * Ding-dong, this is your friendly happy face talking. Please to beade2004-04-031-1/+1 * By default, do not install HTML-formatted man pages.trevor2004-04-033-51/+21 * Fix whitespace.trevor2004-04-031-1/+1 * Correct packing list.trevor2004-04-031-5/+9 * - Support USE_GETOPT_LONGkrion2004-04-038-30/+134 * - Update to version 0.9b-20040316krion2004-04-034-20/+148 * Update to version 0.3.6.archie2004-04-032-4/+3 * Respect CC and CFLAGS.archie2004-04-021-0/+5 * Add p5-POE-Component-EasyDBI 0.02, pOE Component for simplified DBImat2004-04-025-0/+56 * Make examples (mostly) optional, requested by obrien.trevor2004-04-023-590/+20 * Use PERL_MODBUILD now that bsd.port.mk has been changed to allow it withoutkris2004-04-021-19/+1 * Remove category pkg/COMMENT files in favour of a COMMENT variable in thekris2004-04-022-1/+2 * - Unbreak build: correct WRKSRCpav2004-04-021-0/+1 * upgrade to 5.07.1ijliao2004-04-022-5/+3 * Add pear-HTML_QuickForm 3.2.2, a PEAR package providing methodsthierry2004-04-027-0/+139 * Add p5-Parse-CPAN-Packages 2.20, parse 02packages.details.txt.gz frommat2004-04-025-0/+55 * Add p5-CPAN-DistnameInfo 0.03, extract distribution name and versionmat2004-04-025-0/+43 * Update to 0.05.01mat2004-04-012-3/+4 * BROKEN: Unfetchablekris2004-04-011-0/+2 * BROKEN: Unfetchablekris2004-04-011-0/+2 * BROKEN: Does not fetch (size mismatch)kris2004-04-011-0/+2 * Update to 1.09mat2004-04-012-3/+3 * - Remove USE_SIZEkrion2004-04-013-3/+0 * fix master_site groupsijliao2004-04-011-5/+6 * upgrade to 1.040ijliao2004-04-013-5/+13 * - upgrade to 1.0.0;thierry2004-04-012-4/+4 * - Update to 2.0.1krion2004-04-017-35/+38 * Update to 0.07mat2004-03-312-3/+3 * - Add CONFLICTSkrion2004-03-312-0/+4 * - Assign maintainership to Dominic Marks <dom@helenmarks.co.uk>krion2004-03-311-1/+1 * Now there is no need to replace malloc.h with stdlib.hdemon2004-03-311-5/+0 * Update to version 0.1.3.demon2004-03-314-9/+14 * Change the last remaining references to philip@paeps.cx to philip@FreeBSD.org.philip2004-03-311-1/+1 * SIZEify (maintainer timeout)trevor2004-03-31341-0/+369 * Update to 0.43erwin2004-03-313-3/+8 * - Use USE_ICONV knobkrion2004-03-317-11/+11 * Update to 0.73mat2004-03-302-2/+3 * BROKEN on amd64: Does not compilekris2004-03-303-1/+17 * - Update to 2.13clement2004-03-302-5/+4 * - Add PORTDOCSkrion2004-03-301-0/+12 * - Fix installkrion2004-03-304-4/+20 * Updated to 0.13skv2004-03-302-2/+3 * Updated to 0.4skv2004-03-302-2/+3 * Fix one missed instance of pointing to the wrong location in generatedade2004-03-3012-0/+116 * Update to 3.3.1.adamw2004-03-303-3/+17 * - Update to 0.7pav2004-03-305-68/+24 * Add SIZE to distinfo'sade2004-03-3010-0/+10 * Add p5-Class-XPath 1.4, base class to add xpath matching to object trees.mat2004-03-30