aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/mikutter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/mikutter/Makefile')
-rw-r--r--net-im/mikutter/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/net-im/mikutter/Makefile b/net-im/mikutter/Makefile
index fdb1422f5ece..8a0e89bdd829 100644
--- a/net-im/mikutter/Makefile
+++ b/net-im/mikutter/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mikutter
-PORTVERSION= 3.2.2
+PORTVERSION= 3.2.3
CATEGORIES= net-im ruby
MASTER_SITES= http://mikutter.hachune.net/bin/ \
LOCAL/tota/${PORTNAME}
@@ -14,7 +14,7 @@ COMMENT= Simple, powerful, and moeful Twitter client
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= rubygem-gtk2>=2.2.0:${PORTSDIR}/x11-toolkits/rubygem-gtk2 \
+RUN_DEPENDS= rubygem-gtk2>=2.2.5:${PORTSDIR}/x11-toolkits/rubygem-gtk2 \
rubygem-cairo>=1.12.9:${PORTSDIR}/graphics/rubygem-cairo \
rubygem-addressable>=2.3.6:${PORTSDIR}/www/rubygem-addressable \
rubygem-hmac>=0.4.0:${PORTSDIR}/security/rubygem-hmac \
@@ -30,13 +30,13 @@ RUN_DEPENDS= rubygem-gtk2>=2.2.0:${PORTSDIR}/x11-toolkits/rubygem-gtk2 \
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_RUBY= yes
+USES= shebangfix
NO_BUILD= yes
-RUBY_REQUIRE= Ruby >= 200
-RUBY_SHEBANG_FILES= mikutter.rb \
- core/miku/miku.rb \
- core/lib/piapro.rb \
- devel/makechi.rb
+SHEBANG_FILES= mikutter.rb \
+ core/miku/miku.rb \
+ core/lib/piapro.rb \
+ devel/makechi.rb
PORTDOCS= README
SUB_FILES= mikutter.desktop
@@ -50,11 +50,7 @@ NOTIFY_DESC= notify-send support
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
-.include <bsd.port.pre.mk>
-
-.if !defined(RUBY_PROVIDED)
-IGNORE= requires Ruby 2.0.0 or later
-.endif
+.include <bsd.port.options.mk>
HTTPCLIENT_RUN_DEPENDS= rubygem-httpclient>=0:${PORTSDIR}/www/rubygem-httpclient
NOTIFY_RUN_DEPENDS= notify-send:${PORTSDIR}/devel/libnotify
@@ -78,4 +74,4 @@ x-generate-plist: stage
${FIND} ${STAGEDIR}${RUBY_SITELIBDIR}/mikutter -type f | ${SORT} | ${SED} -e 's,${STAGEDIR}${RUBY_SITELIBDIR},%%RUBY_SITELIBDIR%%,' >> pkg-plist.new
${ECHO} share/applications/mikutter.desktop >> pkg-plist.new
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>