aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/openfire
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/openfire')
-rw-r--r--net-im/openfire/Makefile1
-rw-r--r--net-im/openfire/files/patch-pre-xmpp-dialback-fix.diff17
2 files changed, 18 insertions, 0 deletions
diff --git a/net-im/openfire/Makefile b/net-im/openfire/Makefile
index 7c1e789371ba..70a49722d2d6 100644
--- a/net-im/openfire/Makefile
+++ b/net-im/openfire/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openfire
PORTVERSION= 3.7.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net-im java
MASTER_SITES= http://download.igniterealtime.org/openfire/
diff --git a/net-im/openfire/files/patch-pre-xmpp-dialback-fix.diff b/net-im/openfire/files/patch-pre-xmpp-dialback-fix.diff
new file mode 100644
index 000000000000..37ff1faf5c71
--- /dev/null
+++ b/net-im/openfire/files/patch-pre-xmpp-dialback-fix.diff
@@ -0,0 +1,17 @@
+Index: src/java/org/jivesoftware/openfire/session/LocalIncomingServerSession.java
+===================================================================
+--- src/java/org/jivesoftware/openfire/session/LocalIncomingServerSession.java (wersja 12902)
++++ src/java/org/jivesoftware/openfire/session/LocalIncomingServerSession.java (kopia robocza)
+@@ -122,7 +122,11 @@
+ openingStream.append(" xmlns=\"jabber:server\"");
+ openingStream.append(" from=\"").append(serverName).append("\"");
+ openingStream.append(" id=\"").append(streamID).append("\"");
+- openingStream.append(" version=\"1.0\">");
++ if (serverVersion[0] >= 1) {
++ openingStream.append(" version=\"1.0\">");
++ } else {
++ openingStream.append(">");
++ }
+ connection.deliverRawText(openingStream.toString());
+
+ if (serverVersion[0] >= 1) {