aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/p5-Net-Async-XMPP/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/p5-Net-Async-XMPP/Makefile')
-rw-r--r--net-im/p5-Net-Async-XMPP/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/net-im/p5-Net-Async-XMPP/Makefile b/net-im/p5-Net-Async-XMPP/Makefile
index 29bb325e3772..779ecf96283e 100644
--- a/net-im/p5-Net-Async-XMPP/Makefile
+++ b/net-im/p5-Net-Async-XMPP/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Net-Async-XMPP
PORTVERSION= 0.002
+PORTREVISION= 1
CATEGORIES= net-im perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:TEAM
@@ -17,8 +18,7 @@ COMMENT= Asynchronous XMPP client and server
RUN_DEPENDS= p5-IO-Async>=0.37:${PORTSDIR}/devel/p5-IO-Async \
p5-IO-Async-SSL>=0.04:${PORTSDIR}/security/p5-IO-Async-SSL \
- p5-Protocol-XMPP>=0.002:${PORTSDIR}/net-im/p5-Protocol-XMPP \
- p5-parent>=0:${PORTSDIR}/devel/p5-parent
+ p5-Protocol-XMPP>=0.002:${PORTSDIR}/net-im/p5-Protocol-XMPP
PERL_CONFIGURE= yes
@@ -27,4 +27,10 @@ MAN3= Net::Async::XMPP.3 \
Net::Async::XMPP::Protocol.3 \
Net::Async::XMPP::Server.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+.endif
+
+.include <bsd.port.post.mk>