aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/p5-POE-Component-Client-MSN/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/p5-POE-Component-Client-MSN/Makefile')
-rw-r--r--net-im/p5-POE-Component-Client-MSN/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-im/p5-POE-Component-Client-MSN/Makefile b/net-im/p5-POE-Component-Client-MSN/Makefile
new file mode 100644
index 000000000000..e6ba37280dda
--- /dev/null
+++ b/net-im/p5-POE-Component-Client-MSN/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-POE-Component-Client-MSN
+# Date created: 2007/02/14
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Client-MSN
+PORTVERSION= 0.03
+CATEGORIES= net-im perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= POE Component for MSN Messenger
+
+BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-POE-Component-Client-Keepalive>=0:${PORTSDIR}/net/p5-POE-Component-Client-Keepalive \
+ p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-POE-Component-SSLify>=0:${PORTSDIR}/security/p5-POE-Component-SSLify
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= POE::Component::Client::MSN.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>