aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/pidgin-pidgimpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/pidgin-pidgimpd/Makefile')
-rw-r--r--net-im/pidgin-pidgimpd/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-im/pidgin-pidgimpd/Makefile b/net-im/pidgin-pidgimpd/Makefile
new file mode 100644
index 000000000000..45f54144d3b0
--- /dev/null
+++ b/net-im/pidgin-pidgimpd/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: pidgin-pidgimpd
+# Date created: 21 September 2008
+# Whom: hrkfrd@googlemail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= pidgimpd
+PORTVERSION= 1.0
+CATEGORIES= net-im audio
+MASTER_SITES= http://ayeon.org/projects/pidgimpd/
+PKGNAMEPREFIX= pidgin-
+
+MAINTAINER= hrkfrd@googlemail.com
+COMMENT= PidgiMPD is a Pidgin plugin for monitoring/controlling MPD
+
+LIB_DEPENDS= purple.5:${PORTSDIR}/net-im/libpurple \
+ mpd:${PORTSDIR}/audio/libmpd
+BUILD_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
+RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
+
+USE_BZIP2= yes
+USE_GNOME= pkgconfig gtk20
+USE_ICONV= yes
+GNU_CONFIGURE= yes
+
+PLIST_FILES= lib/pidgin/pidgimpd.so \
+ lib/pidgin/pidgimpd.la
+
+.include <bsd.port.mk>