aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/pidgin-pidgimpd
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/pidgin-pidgimpd')
-rw-r--r--net-im/pidgin-pidgimpd/Makefile30
-rw-r--r--net-im/pidgin-pidgimpd/distinfo3
-rw-r--r--net-im/pidgin-pidgimpd/pkg-descr15
3 files changed, 48 insertions, 0 deletions
diff --git a/net-im/pidgin-pidgimpd/Makefile b/net-im/pidgin-pidgimpd/Makefile
new file mode 100644
index 000000000000..45f54144d3b0
--- /dev/null
+++ b/net-im/pidgin-pidgimpd/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: pidgin-pidgimpd
+# Date created: 21 September 2008
+# Whom: hrkfrd@googlemail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= pidgimpd
+PORTVERSION= 1.0
+CATEGORIES= net-im audio
+MASTER_SITES= http://ayeon.org/projects/pidgimpd/
+PKGNAMEPREFIX= pidgin-
+
+MAINTAINER= hrkfrd@googlemail.com
+COMMENT= PidgiMPD is a Pidgin plugin for monitoring/controlling MPD
+
+LIB_DEPENDS= purple.5:${PORTSDIR}/net-im/libpurple \
+ mpd:${PORTSDIR}/audio/libmpd
+BUILD_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
+RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
+
+USE_BZIP2= yes
+USE_GNOME= pkgconfig gtk20
+USE_ICONV= yes
+GNU_CONFIGURE= yes
+
+PLIST_FILES= lib/pidgin/pidgimpd.so \
+ lib/pidgin/pidgimpd.la
+
+.include <bsd.port.mk>
diff --git a/net-im/pidgin-pidgimpd/distinfo b/net-im/pidgin-pidgimpd/distinfo
new file mode 100644
index 000000000000..0dd84db0e50f
--- /dev/null
+++ b/net-im/pidgin-pidgimpd/distinfo
@@ -0,0 +1,3 @@
+MD5 (pidgimpd-1.0.tar.bz2) = bc9806e695220bbe6daea726ae9f8447
+SHA256 (pidgimpd-1.0.tar.bz2) = bcfa507d3299a63ddf4d7543685023b8c2467cf114b202370a5a50d00860140b
+SIZE (pidgimpd-1.0.tar.bz2) = 239870
diff --git a/net-im/pidgin-pidgimpd/pkg-descr b/net-im/pidgin-pidgimpd/pkg-descr
new file mode 100644
index 000000000000..c88d32e7d3ef
--- /dev/null
+++ b/net-im/pidgin-pidgimpd/pkg-descr
@@ -0,0 +1,15 @@
+PidgiMPD is a Pidgin plugin for monitoring/controlling MPD.
+
+PidgiMPD can do both automatic and manual tasks.
+The manual tasks are handled via the command /mpc in conversation windows.
+Help about that command can be found using the parameter help.
+
+The automatic tasks are:
+* Automatically set away message to user defined string OR set Pidgin TUNE
+ status, if available. (TUNE status is supported in MSNP14 and Jabber)
+* Automatically send currently playing song information to users in
+ active conversations.
+
+The syntax of the messages can be user configured.
+
+WWW: http://ayeon.org/projects/pidgimpd/