aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/pidgin-sipe/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/pidgin-sipe/Makefile')
-rw-r--r--net-im/pidgin-sipe/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/net-im/pidgin-sipe/Makefile b/net-im/pidgin-sipe/Makefile
index c2382e42670a..0011a7078024 100644
--- a/net-im/pidgin-sipe/Makefile
+++ b/net-im/pidgin-sipe/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pidgin-sipe
-PORTVERSION= 1.12.0
+PORTVERSION= 1.13.1
CATEGORIES= net-im
MASTER_SITES= SF/sipe/sipe/${DISTNAME}
@@ -27,9 +27,21 @@ PORTDOCS= AUTHORS ChangeLog COPYING HACKING INSTALL NEWS README TODO VERSION
CFLAGS+= "-I/${LOCALBASE}/include"
LIBS+= "-L/${LOCALBASE}/lib"
+OPTIONS= OSC2005 "Message timeout for OCS2005" off \
+ KRB5 "With Kerberos5" off
+
CONFIGURE_ARGS+= --enable-purple \
- --disable-telepathy \
- --without-krb5
+ --disable-telepathy
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_OSC2005)
+CONFIGURE_ARGS+= --enable-ocs2005-message-hack
+.endif
+
+.if defined(WITHOUT_KRB5)
+CONFIGURE_ARGS+= --without-krb5
+.endif
CONFIGURE_ENV+= LIBS="${LIBS}" \
COM_ERR_CFLAGS="-I/usr/include" \