aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/prosody/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/prosody/Makefile')
-rw-r--r--net-im/prosody/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-im/prosody/Makefile b/net-im/prosody/Makefile
index 87122b732a1c..e5103ff9284e 100644
--- a/net-im/prosody/Makefile
+++ b/net-im/prosody/Makefile
@@ -5,12 +5,13 @@ PORTNAME= prosody
PORTVERSION= 0.9.8
CATEGORIES= net-im
MASTER_SITES= http://prosody.im/downloads/source/ \
- http://redundancy.redundancy.org/mirror/
+ http://redundancy.redundancy.org/mirror/
MAINTAINER= lx@FreeBSD.org
COMMENT= Simple extensible XMPP server written in Lua
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${LUA_MODLIBDIR}/socket/core.so:${PORTSDIR}/net/luasocket \
${LUA_MODLIBDIR}/ssl.so:${PORTSDIR}/security/luasec \
@@ -30,7 +31,7 @@ LUAJIT_LIB_DEPENDS= libluajit-5.1.so:${PORTSDIR}/lang/luajit
.include <bsd.port.options.mk>
-USES= gmake lua:51 shebangfix
+USES= cpe gmake lua:51 shebangfix
SHEBANG_LANG= lua
SHEBANG_FILES= prosody prosodyctl
lua_OLD_CMD= ${SETENV} lua