aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/rubygem-lita/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/rubygem-lita/Makefile')
-rw-r--r--net-im/rubygem-lita/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/net-im/rubygem-lita/Makefile b/net-im/rubygem-lita/Makefile
index 8ee5db6a86ab..3e2cb05f3b17 100644
--- a/net-im/rubygem-lita/Makefile
+++ b/net-im/rubygem-lita/Makefile
@@ -2,35 +2,31 @@
# $FreeBSD$
PORTNAME= lita
-PORTVERSION= 3.3.1
+PORTVERSION= 4.3.0
CATEGORIES= net-im rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= Multi-service chat bot with extendable behavior
-RUN_DEPENDS= rubygem-bundler>=1.3:${PORTSDIR}/sysutils/rubygem-bundler \
+LICENSE= MIT
+
+RUN_DEPENDS= redis>=0:${PORTSDIR}/databases/redis \
+ rubygem-bundler>=1.3:${PORTSDIR}/sysutils/rubygem-bundler \
rubygem-faraday>=0.8.7:${PORTSDIR}/www/rubygem-faraday \
rubygem-http_router>=0.11.1:${PORTSDIR}/www/rubygem-http_router \
- rubygem-ice_nine>=0.11.0:${PORTSDIR}/devel/rubygem-ice_nine \
rubygem-i18n>=0.6.9:${PORTSDIR}/devel/rubygem-i18n \
+ rubygem-ice_nine>=0.11.0:${PORTSDIR}/devel/rubygem-ice_nine \
rubygem-multi_json>=1.7.7:${PORTSDIR}/devel/rubygem-multi_json \
rubygem-puma>=2.7.1:${PORTSDIR}/www/rubygem-puma \
rubygem-rack15>=1.5.2:${PORTSDIR}/www/rubygem-rack15 \
rubygem-redis-namespace>=1.3.0:${PORTSDIR}/databases/rubygem-redis-namespace \
- rubygem-thor>=0.18.1:${PORTSDIR}/devel/rubygem-thor \
- redis>=0:${PORTSDIR}/databases/redis
+ rubygem-thor>=0.18.1:${PORTSDIR}/devel/rubygem-thor
USE_RUBY= yes
USE_RUBYGEMS= yes
-RUBYGEM_AUTOPLIST=yes
+RUBYGEM_AUTOPLIST= yes
PLIST_FILES= bin/lita
-.include <bsd.port.pre.mk>
-
-.if ${RUBY_VER} == 1.9
-IGNORE= Requires Ruby 2.0 or newer
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>