aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/skype12/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/skype12/Makefile')
-rw-r--r--net-im/skype12/Makefile66
1 files changed, 66 insertions, 0 deletions
diff --git a/net-im/skype12/Makefile b/net-im/skype12/Makefile
new file mode 100644
index 000000000000..bd96c23808dc
--- /dev/null
+++ b/net-im/skype12/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: skype12
+# Date created: Jun 21. 2004
+# Whom: netchild@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= skype12
+PORTVERSION= 1.2.0.18
+CATEGORIES= net
+MASTER_SITES= NETBSD
+DISTNAME= skype_staticQT-${PORTVERSION}
+
+MAINTAINER= beech@FreeBSD.org
+COMMENT= Legacy version P2P VoIP software
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
+ ${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat
+
+USE_BZIP2= yes
+USE_LINUX= yes
+PORTDOCS= LICENSE README
+SUB_FILES= pkg-message
+
+RESTRICTED= Redistribution prohibited.
+CONFLICTS= skype-1.[0-9].*
+
+OPTIONS= NVIDIA_GL "Enable Nvidia Support" off
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 700000
+BROKEN= Legacy version, Use net/skype
+.endif
+
+.if defined(WITH_NVIDIA_GL)
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+.else
+RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+.endif
+
+WRKSRC= ${WRKDIR}/skype-${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|Exec=skype|Exec=skype --resources=${PREFIX}/${SKYPEDIR}|' \
+ ${WRKSRC}/skype.desktop
+
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/skype
+
+do-install:
+ @${INSTALL} -d ${PREFIX}/share/applications
+ @${INSTALL_PROGRAM} ${WRKSRC}/skype ${PREFIX}/bin/skype
+ @${CHMOD} a+rx ${PREFIX}/bin/skype
+ @${INSTALL_DATA} ${WRKSRC}/skype.desktop ${PREFIX}/share/applications/
+ @${INSTALL_DATA} ${WRKSRC}/icons/skype_48_32.png ${PREFIX}/share/pixmaps/skype.png
+ @cd ${WRKSRC}/&&${COPYTREE_SHARE} "icons sound lang" ${DATADIR}/
+
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>