aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/sulci/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/sulci/Makefile')
-rw-r--r--net-im/sulci/Makefile84
1 files changed, 0 insertions, 84 deletions
diff --git a/net-im/sulci/Makefile b/net-im/sulci/Makefile
deleted file mode 100644
index 369ef8341b3e..000000000000
--- a/net-im/sulci/Makefile
+++ /dev/null
@@ -1,84 +0,0 @@
-# New ports collection makefile for: sulci
-# Date created: Fri Jul 8 13:12:34 MSD 2005
-# Whom: Denis Shaposhnikov <dsh@vlink.ru>
-#
-# $FreeBSD$
-#
-
-PORTNAME= sulci
-PORTVERSION= 0.5.a.20060221
-PORTREVISION= 1
-PORTEPOCH= 2
-CATEGORIES= net-im
-MASTER_SITES= http://www.jabber.ru/files/sulci/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.a./-alpha-/}
-
-MAINTAINER= dsh@vlink.ru
-COMMENT= A Jabber bot
-
-BUILD_DEPENDS= ${LOCALBASE}/lib/ocaml/cryptokit.cma:${PORTSDIR}/security/ocaml-cryptokit \
- ${LOCALBASE}/${OCAML_SITELIBDIR}/ulex/ulexing.a:${PORTSDIR}/devel/ocaml-ulex \
- ${LOCALBASE}/${OCAML_SITELIBDIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net \
- ${LOCALBASE}/${OCAML_SITELIBDIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
-LIB_DEPENDS= sqlite.2:${PORTSDIR}/databases/sqlite2 \
- pcre.0:${PORTSDIR}/devel/pcre
-RUN_DEPENDS= ${LOCALBASE}/${OCAML_SITELIBDIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net \
- mueller:${PORTSDIR}/russian/mueller-dic
-
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_OCAML= yes
-NO_OCAML_RUNDEPENDS= yes
-USE_OCAML_FINDLIB= yes
-USE_RC_SUBR= ${PORTNAME}.sh
-
-ALL_TARGET= subdirs
-PKGMESSAGE= ${WRKDIR}/pkg-message
-SUB_FILES= pkg-message
-
-OPTIONS= MUC_LOG "with muc_log plugin" on
-
-BROKEN= don't work with ocaml 3.10
-DEPRECATED= has been broken for more than 6 months
-EXPIRATION_DATE=2009-01-19
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}/${PORTNAME} ${PREFIX}/sbin
-
- ${MKDIR} ${PREFIX}/libexec/${PORTNAME}
-.for i in lang/langcompile tlds/createtlds utils/wtf/wtf_convert
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}/${i} ${PREFIX}/libexec/${PORTNAME}
-.endfor
-
- ${MKDIR} ${DATADIR}/lang
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/lang/*.htbl ${WRKSRC}/${PORTNAME}/lang/*.msg ${DATADIR}/lang
-
-.for i in tlds.db tlds.txt
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/tlds/${i} ${DATADIR}
-.endfor
-
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/${PORTNAME}.conf.example ${EXAMPLESDIR}
-
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-
-. for i in COPYING
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-. endfor
-
-. for i in cmdlist.en.txt cmdlist.ru.txt
- ${INSTALL_DATA} ${WRKSRC}/docs/sulci/${i} ${DOCSDIR}
-. endfor
-.endif
-
-post-install:
- ${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITHOUT_MUC_LOG)
-EXTRA_PATCHES+= ${FILESDIR}/without-muc-log.patch
-.endif
-
-.include <bsd.port.post.mk>