aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/telepathy-gabble/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/telepathy-gabble/Makefile')
-rw-r--r--net-im/telepathy-gabble/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/net-im/telepathy-gabble/Makefile b/net-im/telepathy-gabble/Makefile
index fad002bd02db..c81c72307afd 100644
--- a/net-im/telepathy-gabble/Makefile
+++ b/net-im/telepathy-gabble/Makefile
@@ -1,33 +1,37 @@
+# Created by: Florent Thoumie <flz@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/net-im/telepathy-gabble/Makefile 17271 2013-04-01 15:16:27Z kwm $
+# $MCom: ports/trunk/net-im/telepathy-gabble/Makefile 19804 2014-08-13 14:55:11Z kwm $
PORTNAME= telepathy-gabble
-PORTVERSION= 0.16.6
-PORTREVISION= 2
+PORTVERSION= 0.18.3
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Jabber Connection Manager for Telepathy Framework
-BUILD_DEPENDS= telepathy-glib>=0.18.0:${PORTSDIR}/net-im/telepathy-glib \
- ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+BUILD_DEPENDS= telepathy-glib>=0.22.0:${PORTSDIR}/net-im/telepathy-glib \
+ ca_root_nss>=0:${PORTSDIR}/security/ca_root_nss
LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
libnice.so:${PORTSDIR}/net-im/libnice \
libtelepathy-glib.so:${PORTSDIR}/net-im/telepathy-glib \
libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid \
libloudmouth-1.so:${PORTSDIR}/net-im/loudmouth
-RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+RUN_DEPENDS= ca_root_nss>=0:${PORTSDIR}/security/ca_root_nss \
+ libnice-gst1>=0:${PORTSDIR}/net-im/libnice-gst1
PORTSCOUT= limitw:1,even
-GNU_CONFIGURE= yes
USES= alias gmake libtool pathfix pkgconfig python:build
USE_GNOME= glib20 libxslt:build
-USE_SQLITE= yes
+USE_SQLITE= 3
USE_OPENSSL= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ca-certificates=${LOCALBASE}/share/certs/ca-root-nss.crt
+CONFIGURE_ENV= LIBS="-pthread"
+INSTALL_TARGET= install-strip
PLIST_SUB= PVERSION=${PORTVERSION}