aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/tox/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/tox/Makefile')
-rw-r--r--net-im/tox/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/net-im/tox/Makefile b/net-im/tox/Makefile
index c7e6213ba3d7..47ed32dd358e 100644
--- a/net-im/tox/Makefile
+++ b/net-im/tox/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= toxcore
-PORTVERSION= 0.1.11
+PORTVERSION= 0.2.0
DISTVERSIONPREFIX= v
-PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net-im net-p2p
@@ -15,13 +14,15 @@ LICENSE= GPLv3
BUILD_DEPENDS= checkmk:devel/check
LIB_DEPENDS= libvpx.so:multimedia/libvpx \
+ libmsgpackc.so:devel/msgpack \
libsndfile.so:audio/libsndfile \
+ libportaudio.so:audio/portaudio \
libsodium.so:security/libsodium \
libopencv_core.so:graphics/opencv-core \
libopus.so:audio/opus \
libconfig.so:devel/libconfig
-TEST_DEPENDS= ${LOCALBASE}/lib/libmsgpackc.so:devel/msgpack \
- ${LOCALBASE}/lib/libportaudio.so:audio/portaudio
+
+CONFLICTS= toxcore-legacy-0.1.*
USE_GITHUB= yes
GH_ACCOUNT= TokTok
@@ -29,7 +30,7 @@ GH_PROJECT= c-toxcore
USES= cmake compiler:c11 libtool pathfix pkgconfig
USE_LDCONFIG= yes
-PLIST_SUB= VER=${PORTVERSION:C/0.//}.0 SO=1
+PLIST_SUB= VER=${PORTVERSION:C/0.//}.0 SO=2
OPTIONS_DEFINE= DAEMON
OPTIONS_SUB= yes