aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/vicq/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/vicq/Makefile')
-rw-r--r--net-im/vicq/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/net-im/vicq/Makefile b/net-im/vicq/Makefile
index 3137b191d01c..7f7383ba757b 100644
--- a/net-im/vicq/Makefile
+++ b/net-im/vicq/Makefile
@@ -21,23 +21,19 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PERL_CONFIGURE= yes
+SIGNAL_PATCH=p5.8-patch-sigalrm
post-extract:
${MV} ${WRKSRC}/Net/vICQ/* ${WRKSRC}
${RM} ${WRKSRC}/install.pl
+post-patch:
+ @${ECHO_MSG} "===> Applying patch ${SIGNAL_PATCH} for ${PKGNAME}"
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/${SIGNAL_PATCH}
+
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/vicq ${PREFIX}/bin
${MKDIR} ${PREFIX}/share/examples/vicq
${INSTALL_DATA} ${WRKSRC}/vicqrc.example ${PREFIX}/share/examples/vicq
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 500800
-SIGNAL_PATCH=p5.8-patch-sigalrm
-post-patch:
- @${ECHO_MSG} "===> Applying patch ${SIGNAL_PATCH} for ${PKGNAME}"
- @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/${SIGNAL_PATCH}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>