aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/angst/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/angst/Makefile')
-rw-r--r--net-mgmt/angst/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/net-mgmt/angst/Makefile b/net-mgmt/angst/Makefile
index 248b6c911500..110fc8a3a8a8 100644
--- a/net-mgmt/angst/Makefile
+++ b/net-mgmt/angst/Makefile
@@ -8,7 +8,7 @@
PORTNAME= angst
PORTVERSION= 0.4b
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
${MASTER_SITE_PACKETSTORM:S:%SUBDIR%:sniffers/angst:}
@@ -17,17 +17,19 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= An active sniffer
-BUILD_DEPENDS= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
-
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet-config
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
MAN8= angst.8
PLIST_FILES= sbin/angst
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+
post-patch:
- @${REINPLACE_CMD} -e "s,^CC,#CC,g ; \
- s,^CFLAGS,#CFLAGS,g ; \
- s,libnet-config,${LIBNET_CONFIG},g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -Ee \
+ 's,^(CC|CFLAGS).*,#&,; \
+ s,libnet-config,${LIBNET_CONFIG},; \
+ s,--defines,& --cflags,' \
+ ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
5e0f37f47ca9274d3cc6633ed687cc7dc23ca'>Half of these ones missed yesterday while converting to USE_REINPLACE.edwin2002-11-051-1/+2 * - Upgrade to version 0.7, which is against XFree86 4.1.0 .sada2002-05-184-7/+11 * Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;knu2002-01-291-8/+8 * Fixed MASTER_SITES .sada2001-08-171-2/+2 * Upgrade xjman to version 0.6, this is for XFree86 4.x.sada2001-08-083-4/+5 * Cope with update of bsd.man.mk .sada2001-08-06