aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/chillispot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/chillispot/Makefile')
-rw-r--r--net-mgmt/chillispot/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/net-mgmt/chillispot/Makefile b/net-mgmt/chillispot/Makefile
index e6ddd4d174e7..e7b261416525 100644
--- a/net-mgmt/chillispot/Makefile
+++ b/net-mgmt/chillispot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= chillispot
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= http://www.chillispot.org/download/ \
http://www.geeklan.co.uk/files/ \
@@ -20,10 +20,12 @@ GNU_CONFIGURE= yes
USE_GETOPT_LONG=yes
CONFIGURE_TARGET=-build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS=-sysconfdir=${PREFIX}/etc
+USE_RC_SUBR= chillispot.sh
+SUB_FILES= pkg-message
MAN8= chilli.8
OPTIONS= RAW "Latest Release Of Apache & mySQL" Off \
- MATURE "Stable Releases of Apache & mySQL" Off \
+ MATURE "Stable Releases of Apache with mod_ssl & MySQL" Off \
FREE "freeRADIUS" Off \
OPENR "openradius" Off
@@ -35,7 +37,7 @@ RUN_DEPENDS+= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache20 \
.endif
.if defined(WITH_MATURE)
-RUN_DEPENDS+= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache13 \
+RUN_DEPENDS+= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache13-modssl \
${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mysql41-server
.endif
@@ -50,11 +52,14 @@ RUN_DEPENDS+= radiusd:${PORTSDIR}/net/openradius
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DATADIR}
- ${INSTALL_MAN} ${WRKSRC}/doc/chilli.conf ${DATADIR}/chilli.sample
+ ${INSTALL_MAN} ${WRKSRC}/doc/chilli.conf ${DATADIR}/chilli.conf.sample
${INSTALL_MAN} ${WRKSRC}/doc/dictionary.chillispot ${DATADIR}
${INSTALL_MAN} ${WRKSRC}/doc/freeradius.users ${DATADIR}
${INSTALL_MAN} ${WRKSRC}/doc/hotspotlogin.cgi ${DATADIR}
+ ${INSTALL_MAN} ${FILESDIR}/installguide.txt ${DATADIR}
+ ${INSTALL_MAN} ${FILESDIR}/pf.conf.sample ${DATADIR}
+ ${INSTALL_MAN} ${FILESDIR}/ipfw-config.sample ${DATADIR}
.endif
- ${CAT} ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
an> * Part 1 at removing now useless FETCH_ARGS redifitionbapt2014-01-031-1/+0 * - rename AL2 to APACHE20 in Mk/bsd.licenses.db.mkohauer2013-12-311-1/+1 * Upgrade from 2.2.2 to 3.0.4.osa2013-11-263-5/+47 * Add NO_STAGE all over the place in preparation for the staging support (cat: ...bapt2013-09-201-0/+1 * Convert benchmarks from USE_GMAKE to USES=gmakebapt2013-08-311-1/+1 * Fix fetching by update to 2.2.2.osa2013-07-132-7/+7 * Fix fetch by upgrade from 1.2.0 to 2.0.0.osa2013-05-112-4/+4 * Fix fetch by update from 1.1.1 to 1.2.0.osa2013-04-172-4/+4 * Update from 1.0.0 to 1.1.1.osa2013-03-203-11/+7 * - Mark BROKEN on FreeBSD 7.x: does not linkbeat2012-09-261-1/+7