aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/grepcidr
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/grepcidr')
-rw-r--r--net-mgmt/grepcidr/Makefile27
-rw-r--r--net-mgmt/grepcidr/distinfo2
-rw-r--r--net-mgmt/grepcidr/pkg-descr15
3 files changed, 44 insertions, 0 deletions
diff --git a/net-mgmt/grepcidr/Makefile b/net-mgmt/grepcidr/Makefile
new file mode 100644
index 000000000000..7a786f837266
--- /dev/null
+++ b/net-mgmt/grepcidr/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: grepcidr
+# Date created: 2005-04-24
+# Whom: Douglas Fraser <doug@idmf.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= grepcidr
+PORTVERSION= 1.3
+CATEGORIES= net-mgmt textproc
+MASTER_SITES= http://www.pc-tools.net/files/unix/
+
+MAINTAINER= doug+ports@idmf.net
+COMMENT= Filter IP addresses matching IPv4 CIDR/network specification
+
+PLIST_FILES= bin/grepcidr
+
+USE_REINPLACE= yes
+
+do-configure:
+ @${REINPLACE_CMD} \
+ -e 's|/usr/local/bin|${PREFIX}/bin|' \
+ -e 's|-s -O3 -Wall -pedantic|${CFLAGS}|' \
+ -e 's|gcc|${CC}|' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/grepcidr/distinfo b/net-mgmt/grepcidr/distinfo
new file mode 100644
index 000000000000..7fc58e8e2a18
--- /dev/null
+++ b/net-mgmt/grepcidr/distinfo
@@ -0,0 +1,2 @@
+MD5 (grepcidr-1.3.tar.gz) = 7ccade25ce9fe6d6a02348ba8e4cf4a3
+SIZE (grepcidr-1.3.tar.gz) = 21691
diff --git a/net-mgmt/grepcidr/pkg-descr b/net-mgmt/grepcidr/pkg-descr
new file mode 100644
index 000000000000..67788d949d01
--- /dev/null
+++ b/net-mgmt/grepcidr/pkg-descr
@@ -0,0 +1,15 @@
+grepcidr can be used to filter a list of IP addresses against one
+or more Classless Inter-Domain Routing (CIDR) specifications, or
+arbitrary networks specified by an address range. As with grep,
+there are options to invert matching and load patterns from a file.
+grepcidr is capable of comparing thousands or even millions of IPs
+to networks with little memory usage and in reasonable computation
+time.
+
+grepcidr has endless uses in network software, including: mail
+filtering and processing, network security, log analysis, and many
+custom applications.
+
+
+Author: Jem Berkes
+WWW: http://www.pc-tools.net/unix/grepcidr/