aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/icingaweb2-module-cube/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/icingaweb2-module-cube/Makefile')
-rw-r--r--net-mgmt/icingaweb2-module-cube/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-mgmt/icingaweb2-module-cube/Makefile b/net-mgmt/icingaweb2-module-cube/Makefile
new file mode 100644
index 000000000000..8bca9414b283
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-cube/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= icingaweb2-module-cube
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.0
+CATEGORIES= net-mgmt www
+
+MAINTAINER= lme@FreeBSD.org
+COMMENT= Drill-down view for Icinga web 2 based on custom variables
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= icingaweb2>=2.4.1:net-mgmt/icingaweb2
+
+USE_GITHUB= yes
+GH_ACCOUNT= icinga
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+WWWDIR?= ${PREFIX}/www/icingaweb2/modules/${PORTNAME:C/^.*-//}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+
+.include <bsd.port.mk>