aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/isic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/isic/Makefile')
-rw-r--r--net-mgmt/isic/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/net-mgmt/isic/Makefile b/net-mgmt/isic/Makefile
index 381810a88b66..2db223097ea9 100644
--- a/net-mgmt/isic/Makefile
+++ b/net-mgmt/isic/Makefile
@@ -7,6 +7,7 @@
PORTNAME= isic
PORTVERSION= 0.07
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,10 +16,18 @@ EXTRACT_SUFX= .tgz
MAINTAINER= wxs@atarininja.org
COMMENT= IP Stack Integrity Checker
-BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
MAN1= isic.1
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lnet|`${LIBNET_CONFIG} --libs`|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|libnet-config|${LIBNET_CONFIG}|' \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>