aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/nagiosql/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/nagiosql/Makefile')
-rw-r--r--net-mgmt/nagiosql/Makefile26
1 files changed, 19 insertions, 7 deletions
diff --git a/net-mgmt/nagiosql/Makefile b/net-mgmt/nagiosql/Makefile
index 5440b081ce6d..0f91c126f8c3 100644
--- a/net-mgmt/nagiosql/Makefile
+++ b/net-mgmt/nagiosql/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= nagiosql
-PORTVERSION= 3.0.4
+PORTVERSION= 3.1.1
CATEGORIES= net-mgmt www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/NagiosQL%20${PORTVERSION}/
-DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/.//g}
MAINTAINER= chris@smartt.com
COMMENT= A web based administration tool for Nagios
@@ -17,10 +17,12 @@ COMMENT= A web based administration tool for Nagios
RUN_DEPENDS= nagios:${PORTSDIR}/net-mgmt/nagios \
${PEARDIR}/HTML/Template/IT.php:${PORTSDIR}/devel/pear-HTML_Template_IT
+LICENSE= GPLv2
+
USE_BZIP2= yes
USE_MYSQL= yes
USE_GETTEXT= yes
-USE_PHP= mysql gettext ftp session
+USE_PHP= mysql gettext ftp session simplexml
IGNORE_WITH_PHP=4
WANT_PHP_WEB= yes
@@ -30,13 +32,23 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
PEARDIR?= ${LOCALBASE}/share/pear
-NAGIOSQL_FILES= admin admin.php config favicon.ico functions images index.php install templates
+
+OPTIONS= CURL "Configure with cURL support" off \
+ SSH2 "Configure with SSH2 support" off
+
+#.include <bsd.port.pre.mk>
+
+.if defined(WITH_CURL)
+USE_PHP+= curl
+.endif
+
+.if defined(WITH_SSH2)
+USE_PHP+= ssh2
+.endif
do-install:
${MKDIR} ${WWWDIR}
-.for i in ${NAGIOSQL_FILES}
- cd ${WRKSRC} && ${COPYTREE_SHARE} ${i} ${WWWDIR}
-.endfor
+ ${CP} -R ${WRKSRC}/${PORTNAME}/ ${WWWDIR}
${CHOWN} ${WWWOWN}:${WWWGROUP} ${WWWDIR}/config
post-install: