aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/net-snmp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/net-snmp/Makefile')
-rw-r--r--net-mgmt/net-snmp/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index c96468c7e272..f4bfbd45f10c 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -51,6 +51,7 @@ CONFIGURE_ARGS+=--enable-shared --enable-internal-md5 \
--with-logfile="${NET_SNMP_LOGFILE}" \
--with-persistent-directory="${NET_SNMP_PERSISTENTDIR}" \
--with-gnu-ld --with-libwrap \
+ --with-libs="-lssp_nonshared" \
--with-ldflags="-lm -lkvm -ldevstat -L${PKG_PREFIX}/lib -L${LOCALBASE}/lib ${LCRYPTO}"
SUB_FILES= pkg-message
@@ -145,15 +146,7 @@ NET_SNMP_SYS_CONTACT?= nobody@nowhere.invalid
NET_SNMP_SYS_LOCATION?= somewhere
NET_SNMP_LOGFILE?= /var/log/snmpd.log
NET_SNMP_PERSISTENTDIR?=/var/net-snmp
-NET_SNMP_WITH_MIB_MODULE_LIST+= host disman/event-mib mibII/mta_sendmail mibII/tcpTable ucd-snmp/diskio
-
-.if ${OSVERSION} >= 700028
-NET_SNMP_WITH_MIB_MODULE_LIST+= sctp-mib
-.endif
-
-.if ${OSVERSION} >= 800000
-CONFIGURE_ARGS+= --with-libs="-lssp_nonshared"
-.endif
+NET_SNMP_WITH_MIB_MODULE_LIST+= host disman/event-mib mibII/mta_sendmail mibII/tcpTable ucd-snmp/diskio sctp-mib
.if ${OSVERSION} >= 1000000 && ${OSVERSION} < 1100062
CFLAGS+= -D_WANT_IFADDR