aboutsummaryrefslogtreecommitdiffstats
path: root/net-mgmt/p5-Altoids/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/p5-Altoids/Makefile')
-rw-r--r--net-mgmt/p5-Altoids/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-mgmt/p5-Altoids/Makefile b/net-mgmt/p5-Altoids/Makefile
new file mode 100644
index 000000000000..b05a2d1353a5
--- /dev/null
+++ b/net-mgmt/p5-Altoids/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-SNMP_Session
+# Date created: 13 June 1999
+# Whom: Bill Fumerola <billf@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Altoids
+PORTVERSION= 1.017
+CATEGORIES= net perl5
+MASTER_SITES= http://dave.plonka.us/Altoids/%SUBDIR%/
+MASTER_SITE_SUBDIR= . old
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= billf@FreeBSD.org
+COMMENT= SNMP get/walk functionality with built-in name to OID translation
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/SNMP_Session.pm::${PORTSDIR}/net/p5-SNMP_Session
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS+= --with-perllib=${SITE_PERL} \
+ --with-oids=${LOCALBASE}/share/${PORTNAME:L}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>